I tried setting wrapper.java.maxmemory=1300 parameter in c:\Program Files (x86)\GeoServer 2.11.1\wrapper\wrapper.conf but I can't set more than 1300MB (geoserver service can't start). I tried configure Java with -Xmx2048m, for example, command line argument but it ignored. How to increase max heap size up to 8GB, for example? Problem is than the GeoServer can't generate big rasters or kmz's on GetMap operation. Maximum about 500MB.


With 32-bit Java the theoretical maximum is 2 GB and in practice less. For big rasters it is absolutely best to use 64-bit Java.

I see that you have installed your GeoServer with the Windows installer to run as a Windows service. Unfortunately that installation option does not work with 64-bit Java. At least you can make it to work by installing GeoServer from the binary zip and start the server manually. If your system does not select 64-bit Java automatically you can either set it with JAVA_HOME environment variable or then you can edit the startup.bat and point it to use 64-bit Java.

  • Thanks for quick answer. I installed 64 bit Java instead 32 bit and it helped me. GeoServer work fine with 64 bit Java. Now Java may get up to 8GB of RAM. – Pavel Aristarhov Feb 1 '18 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.