3

I am trying to frame a Web Feature Service GET Request applying the INTERSECT filter but I am getting the following error. :

<ows:ExceptionReport xmlns:ows="http://www.opengis.net/ows" version="1.1.0" 
language="en">
<ows:Exception exceptionCode="NoApplicableCode">
<ows:ExceptionText>Wrong coordinates.</ows:ExceptionText>
</ows:Exception>
</ows:ExceptionReport>

The request that I created is as follows :

"fluggs.wupperverband.de/secman_wss_v2/service/WFS_WV_Oberflaechengewaesser_EZG/guest?Request=GetFeature&typeName=secman_WFS_WV_Oberflaechengewaesser_EZG:Fliessgewaesser&Filter=<ogc:Filter><ogc:Intersects><ogc:PropertyName>Shape</ogc:PropertyName><gml:Polygon><gml:exterior><gml:LinearRing><gml:posList>51.293792 7.051833 51.309247 7.280830 51.218159 7.242377 51.205900 7.043937 51.293792 7.051833</gml:posList></gml:LinearRing></gml:exterior></gml:Polygon></ogc:Intersects></ogc:Filter>" 

Where am I going wrong?

  • 1
    I have no idea about what is the reason for Wrong coordinates but you have some other errors. First, write always complete request which include also service=WFS&version=1.1.0 so it is explicit for you and others which version you are using. You filter seems to be in EPSG:4326 but you do not show it with srsName. When you have made the request to work technically you will get an empty result because the feature type is natively in EPSG:25832. Either write the filter as well in EPSG:25832 or add the srsName to tell that it is in EPSG:4326. – user30184 Feb 1 '18 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.