0

I'm trying to install the i.atcorr extension on GRASS 7.4.0 using the following (Running Linux Mint 18.3):

g.extension extension=i.atcorr url=trac.osgeo.org/grass/browser/grass/trunk/imagery/i.atcorr

Which always returns

ERROR: Extension <i.atcorr> not found

The following also returns the same error message:

g.extension extension=i.atcorr url=http://trac.osgeo.org/grass/browser/grass/trunk/imagery/i.atcorr?format=zip

Is this the correct way to install extensions from OSgeo, or is this even the correct url to the extension source code?

1

i.atcorr is not an extension, it is part of the installation.

In theory, you could be able to download any module that way, but trac.osgeo.org is not configured for downloading folders from trunk, it only works for addons. If you somehow get the zipped folder, you can install a module from a zip file using g.extension.

  • Alas, why I shouldn't work late at night. I assumed it was an extension and didn't even check if it was a standard module. Thanks for putting me straight :) – scabecks Feb 4 '18 at 2:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.