1

Add Delimited Text Layer dialog does not have anywhere to specify the CRS of the data. The layer imports, but defaults to WGS84, which in this case is not correct (it needs to be geographic, but with a different datum).

When importing it gives an error message that CRS was not specified, so it defaulted to WGS84.

I believe previously (earlier QGIS versions) this used to open the CRS dialog when the add layer dialog was dismissed with "OK".

As a work around, you can reset the CRS in the layer properties after it is imported. This seems to work OK, so this is not an emergency, but it seems a little kludgy;>)

I am using QGIS 2.18.16 in Ubuntu 16.04.

5

Have you checked the default setting?

  • Settings -> Options... -> CRS -> CRS for new layers (Prompt for CRS)
  • That was exactly it! It was set to default to WGS84. Makes me feel a little silly;>) Thanks much. – ZanStrausz Feb 3 '18 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.