0

I am setting up local stack of pgadmin4 (v2), geoserver (2.12.1) and geonetwork (3.4)(on tomcat 9).

I've been testing to see if the layers i've uploaded to pgadmin and added to geoserver work, and they do. I can easily add them as a wms service with QGIS.

However, I am trying to add them also to map of geonetwork, and it doesn't seem to work. No matter which layer I use, it won't work. Even other WMS services that I know work.

I get this error:

error message

Something went wrong while loading tile 'http://localhost:8080/geoserve ...' for layer 'river_ciliwung[3857]'.

Very strange, because geonetork is able to do a WMSrequest GetCapabilities no problem.

See picture, it retrieves all the layers:

get capabilities request

furthermore, I used chrome (f12) to inspect the requests, and this is also very strange. GeoNetwork does a bunch of requests and they all get canceled.

enter image description here

How do I add a wms map layer to the geonetwork map?

  • Maybe your WMS layer doesn't support the CRS GN map is using... – juanluisrp Feb 5 '18 at 19:31
  • good point...what is the CRS GeoNet is using? – J.A.Cado Feb 6 '18 at 1:52
  • I found it, it has epsg:3857. So that can't be the case. – J.A.Cado Feb 6 '18 at 2:24
  • Is there some additional information i could provide? I am clueless, I have exhausted online documentation, so any tips would be great. – J.A.Cado Feb 6 '18 at 4:48
  • 1
    You can try this. In the GUI settings page, localhost:8080/geonetwork/srv/eng/admin.console#/settings/ui, uncheck the option_Export map as image_ to make Openlayers use the classic <img src="..." > for the tiles instead of the <canvas> element. – juanluisrp Feb 6 '18 at 10:53
2

Login as an admin, go to the admin console -> Settings -> User interface tab and uncheck the box Export map as image ( http://example.com/geonetwork/srv/eng/admin.console#/settings/ui).

Export map as image option disabled This will make GN use the classic <img src="..."> for rendering the map instead of using a <canvas> element that is blocked by the browser if the WMS images don't come with the right Access-Control-Allow-Origin header to enable CORS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.