7

I am experiencing a strange behavior when symbolizing a point layer using any kind of Feature Blending.

I am currently using QGIS 2.18.16 but I have seen this in previous versions (edit: tried now in QGIS 3.0.0 and the problem is still there). What happens is when some points are in the same exact coordinate, the feature blending shows the bounding box of the circle representing the point.

enter image description here

Is there any way to avoid this? Has anyone detected this behavior? I guess this is a general bug but maybe is something related to our video card.

Edit: Stranger things even stranger. If I set all symbol colors to transparent, I can get a map of just the bounding boxes of the overlapping points.

enter image description here enter image description here

Taking a closer look at the screen, the bounding box appears always but you can notice it better when the points overlap since it is almost transparent.

The composer manager has a different behavior. It doesn't show the bounding boxes and when exporting the map the bounding box is not there. We have tried this in three computers and the result is the same.

  • Odd. I can't reproduce with 2.18.16 and a HD520 graphics card. Can you reproduce after restarting QGIS? A fresh project? – mixedbredie Feb 7 '18 at 11:18
  • What are you using to create that circle symbol. An Image? – Alexandre Neto Feb 7 '18 at 11:49
  • @mixedbredie Yes, it happens all the time. We are using NVIDIA Quadro K600 – Albert Feb 7 '18 at 12:13
  • @AlexandreNeto No, a shapefile point layer – Albert Feb 7 '18 at 12:14
  • 1
    Did you tried the approach with ellipse marker with symbol height and width with same values ( creating a circle) ? – LaughU Feb 8 '18 at 8:40
6

as discussed in the comments and just adding it for compilation:

Another hack might be to use ellipse markers with the same value for symbol height and symbol width, which consequently create a circle and thus might be more performant than using a geometry generator for large point clouds.

  • 1
    Yes, it is definitively faster in performance! – Albert Feb 8 '18 at 10:50
  • glad I could help :) – LaughU Feb 8 '18 at 10:55
  • 1
    Still, the issue you faced sounds like a bug. You should report the issue. – Alexandre Neto Feb 8 '18 at 15:30
7

Well, there is a workaround using the geometry generator.

When representing a buffer of the point layer (buffer( $geometry,15)) instead of a simple marker, the bounding box shadow doesn't appear.

enter image description here

Still, it is a strange behavior and for the comments it seems not universal at all..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.