I work in an office of 10 people. We all use QGIS. I also use ArcGIS.

Currently all our GIS data are stored (thus duplicated) on everyone's induvidual hard drives. Any major updates I make are copied over manually from my machine to theirs.

We want to move to having the data in a single location. I thought that by installing PostgresSQL with PostGIS on my machine, and importing the data using pgAdmin, I'd be able to access the same data on my colleague's machine. However, I can only connect to the database (in QGIS) on my machine.

My question is: how can I share my PostGIS database with others in my office?

  • We had a similar situation in our office a few years back. We installed PostgresSQL on a server (mac mini with macOS server) and all 5 team members had own (limited) user rights (defined within pgAdmin (that programm serves as GUI for the server) and so were able to access the DBs through QGIS. It worked pretty well. I did not install it myself, therefor I can't provide a step by step guide and therefor only comment and not answer your question!
    – Kevkev770
    Feb 7, 2018 at 15:44
  • 4
    This is a basic PostgreSQL administration issue. By default, PG only allows minimal privileges, so you need to configure it to allow network access from your colleagues. You should create login roles for each user and a group role to grant access, as any book on database administration will recommend.
    – Vince
    Feb 7, 2018 at 15:48
  • 1
    Whoever deals with your network should be able to sort out the details of that side of things. But then you will need to set up a user group and roles in the database. See gis.stackexchange.com/questions/232945/… this has details of some of the steps Feb 7, 2018 at 15:48
  • @MartinHügi FYI, we currently use Dropbox as our 'network' for file sharing. We do not have an internal server as such. We also don't have anyone who deals with our network anyway (we have no IT professional). I'm doing this by myself with limited knowledge of network infrastructure. :(
    – Theo F
    Feb 7, 2018 at 16:27
  • 1
    By default, Postgres does not accept connections from other machines. To change this you need to update two configuration files: pg_hba.conf and postgresql.conf. See thegeekstuff.com/2014/02/enable-remote-postgresql-connection/…
    – dbaston
    Feb 7, 2018 at 20:38


Browse other questions tagged or ask your own question.