0

I have four rasters with cells of 5x5 arc minutes. I transformed the rasters to vectors/ shapefiles. The cells overlap, so I used intersect to combine the layers. It dawns on me that this was not very efficient, and clip might have done a better/ faster job. Nonetheless, it should have yielded the correct results.

However, for some reason I receive most awkward results: For three of the four layers, seemingly every FID is double. When looking at each of these pairs, one sees that the fourth layer displays a zero one row and the correct value for the other row. I know that the value > zero is correct, because this is the value I get when I check the original shapefile.

What has gone wrong and how can I fix it?

  • The question isn't very clear, what are you expecting to see in the results (a diagram may help to clarify). A Union may be a better option for combining the four shapefiles. – Dan Feb 7 '18 at 22:23
  • I tried Union and the results are the same, but probably Union is more efficient. However, I found out what apparently caused the issue; I explain with an answer. – user108014 Feb 8 '18 at 9:15
1

Apparenetly an error occurred when converting the raster to a polygon. I polygonised the raster again and re-did the operation and no problems ocurred.

FYI: The problem I had looked as follows:

FID_layer1 value_layer1 FID_layer2 value layer2

.........1................5...................1...............10

.........20..............0...................1...............10

.........2................8...................1...............13

.........21..............0...................1...............13

ArcGIS basically treated layer 1 like two layers. One with the correct values, and one consisting solely of zeros.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.