0

I'm trying to create a layer from a selection in another layer in ArcMap 10.5.1 like so...

enter image description here

Doing Right Click Layer - > Selection - > Create Feature from Selected Features after doing my Select by Attributes and Locations. Those are just a Select by Attribute of this PREFIXDIR = 'W' AND STREETNAME = 'WILLOW' AND STREETSUF = 'ST' and then select by location all locations like such...

enter image description here

Then creating the new layer and showing that...

enter image description here

All is great! But as soon as I try to label the features/symbolize like the previous layer...it brings back all the non-selected features.

Using the following Python expression to label...

enter image description here

And the symbolology I'm just importing from the previous layer.

As soon as I label or import symbology all the previous features are brought back...

Like for example when I import the symbology

enter image description here

Anyone know what I'm doing wrong?

2

This appears to be a bug in ArcMap according to some discussion on Esri website.

A work around is to export the selection as a feature class. Right click the layer -> Data -> Export Data -> Then export selected features using the same coordinate system from this layer's source data.

enter image description here

Do the symbology and labeling and it works :)

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.