1

I have setup PostgreSQL 9.5 on my local machine. I am trying to create a database connection from a coworkers laptop on the office network (let's say the network IP is 192.168.1.X). My database server is currently just called localhost (on port 5432). I was able to connect it to ArcGIS Desktop10.5 on the same machine using the add Database Connection option in ArcCatalog, no problem. So, I want to do the same on my coworkers computer. When I try, I get an "Unable to make database connection..." error.

enter image description here

I have configured my pg_hba.conf file multiple times to make sure that any computer on the networks (either 192.168.1.1 - the wifi or 10.1.10.1 - the ethernet) can access it (with database authentication of course). I followed these ESRI configuration instructions. enter image description here

Is there something I am missing?

Is there something else I need to do to make the database connection to postgres?

Can anyone see a problem with my pg_hba.conf file or with using "localhost" as the database instance?

  • host all all 0.0.0.0/0 md5 will allow all ip's and users to access so it might be a windows firewall setting. – Mapperz Feb 7 '18 at 20:40
  • What is in your postgresql.conf file? stackoverflow.com/questions/18580066/… – Mapperz Feb 7 '18 at 20:41
  • If the first image is from your coworker's computer, you might need need to replace 'localhost' with the IP of your machine. 'localhost' always refers to the machine itself (every machine is its own localhost). – Brynne Feb 7 '18 at 20:45
  • As per the Tour there should be only one question asked per question. – PolyGeo Feb 7 '18 at 20:45
  • you need to put YOUR computers ip address or computer name then a comma then the port. – ziggy Feb 7 '18 at 20:50
1

OK, for the edification of anyone who runs into this problem; here is my answer. I am 99.9% positive that this issue was directly caused by a combination of McAfee and my personal computer firewall settings. Essentially, I completely removed McAfee and Turned Windows Defender Firewall off on my Private network (it's still set to On for Public). I was able to make the connection to the Postgres server using the , 5432 and find the specific database I wanted. Now I just need to figure out how to safely setup a Inbound Rule in the advanced setting of my firewall to allow connections from other machines on my network. If anyone has any advice on that, let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.