1

I have four files: .prj, .qpj, .shp and .shx.

They are properly read by Luciad (it seems that only .shp and .prj are necessary for that).

Now I would like to import shapes into QGIS taking into account projection (that doesn't happen). I'm using "Add Vector Layer" option for this, maybe that's the problem?

I searched for it a lot and from what I understand .qpj is some QGIS equivalent of .prj. Mine look quite similar. But I'm still not sure which CRS should I use and how, I guess it should be somehow possible with those files.

My .prj:

GEOGCS["GCS_WGS_1984",DATUM["D_WGS_1984",SPHEROID["WGS_1984",6378137,298.257223563]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]]

My .qpj:

GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]]

How do I know that projection isn't applied? I can only suppose that - this is example comparision between QGIS layer and Luciad map result (expected):

enter image description here

Maybe I shouldn't mention Luciad here, because it's not that related, but that's how I know that my data are good.

EDIT: I see that .qpj/.prj file is used (if none of them is present, QGIS asks me for a CRS, but it doesn't seem to make any difference when I choose just default WGS 84). However, for some reason something (CRS?) from those files isn't applied in the way I want - like in Luciad.

closed as off-topic by underdark Feb 9 '18 at 19:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • what happens if you choose CRS 7030 in Set CRS? – Elio Diaz Feb 7 '18 at 23:14
  • 2
    @ElioDiaz likely nothing as the two occurrences of 7030 in EPSG are a transformation and an ellipsoid. There's no CRS with an ID of 7030. – mkennedy Feb 8 '18 at 1:31
  • My guess is that Luciad's display is not pseudo-plate carree but some other projected CRS or orthographic emulating a 3D view. When you use a geographic CRS QGIS (or ArcGIS), the angular units are treated as if they're linear. That will stretch data east-west as you move away from the equator. – mkennedy Feb 8 '18 at 1:37
  • the shape will depend on what the project's crs is set to, look in the lower right corner – Ian Turton Feb 8 '18 at 9:05
  • @ElioDiaz you mean right click on layer -> "Set Layer CRS"? Could you help mi with finding it? – Line Feb 8 '18 at 9:34
0

Worked when I set project CRS to WGS 84 / Pseudo Mercator (EPSG:3857) before importing layer.

Not the answer you're looking for? Browse other questions tagged or ask your own question.