1

I have two 64 bit computers. My work computer is running Windows 7, my home computer is running Ubuntu 16.04. Both computers have QGIS 2.18 installed on them. Both computers have similar RAM and graphics cards. I have some QGIS projects stored on an external hard-drive that were largely developed on Ubuntu.

When exporting these projects either PDFs or TIFFs from the Windows machine the hillshade is not included in the export. On the Ubuntu machine everything seems to export just fine.

I have read some posts about unchecked layers in the layers panel causing rendering issues. I have ensured that there are no unchecked layers in these projects.

I have saved the Windows project as a separate QGS file and that did not make a difference on the output. I can confirm the problem exists with two different QGS files although both projects were largely drafted on Ubuntu QGIS.

Why can I not export correctly on the Windows version of QGIS? I am trying to incorporate QGIS into my workflow so relying on my Ubuntu box at home is not an option.

  • Is the hillshade a raster layer? If you're just using the hillshade styling, try instead to create a real hillshade raster and transfer that between the machines. – Micha Feb 9 '18 at 11:14
  • @Micha, no the hillshade is a geo-tiff not just hillshade styling. – GBG Feb 9 '18 at 15:35
  • So can you display it independently of the particular QGIS project, in both OS's? – Micha Feb 10 '18 at 14:13
  • @Micha. The hillshade layer? The hillshade is visible in both the Windows and Linux QGIS projects and in a new project as well. Are you suggesting that the hillshade file might be corrupted? – GBG Feb 12 '18 at 16:14
  • Well, now you have verified that the hillshade raster is fine. I have not seen any problems displaying or saving PDF of a project with hillshading. Can't help any further. – Micha Feb 13 '18 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.