4

I add the following WFS address to ArcCatalog just fine and the different feature classes show up in ArcCatalog. However, when I attempt to drag or add a feature into the TOC of ArcMap, it gives me a "This dataset appears to be invalid" error and the feature gets added to the TOC but is empty with no feature records.

Could I be missing a step here? I'm using ArcGIS 10.1. Here is the WFS address:

http://ogi.state.ok.us/geoserver/wfs?service=WFS&version=1.0.0&request=GetFeature&
  • I tried adding it in ArcMap 10 SP 4, and I didn't see any layers listed with the Service at that URL – Roy Jun 8 '12 at 17:33
  • @Roy So you went into Connection Properties after right-clicking the *.fdl file under Interoperability Connections and clicked "Settings"(Parameter button in 10.1) button and don't see list of features under the Constraints>Feature Types button? – wilbev Jun 8 '12 at 18:04
  • Sorry about that, I added it as a WMS -- I'm able to add layers from the WFS through interoperability connections. – Roy Jun 8 '12 at 18:28
  • Yep, it can be added thru interoperability connections. So do you get the same error and empty feature class when trying to add a layer to ArcMap? – wilbev Jun 8 '12 at 18:43
  • 1
    I have the same problem. ArcMap 10.1 release version. @wilbev: did you find an answer? – Claus_L Jun 21 '12 at 6:07
2

In this case I think the problem is to do with the configuration of the WFS service, not with ArcGIS.

The Service URL is:

http://ogi.state.ok.us/geoserver/wfs?

And the GetCapabilities request is like below:

http://ogi.state.ok.us/geoserver/wfs?service=WFS&request=GetCapabilities&

or if you specify a version number like:

http://ogi.state.ok.us/geoserver/wfs?service=WFS&request=GetCapabilities&version=1.1.0&

If you add the service URL to ArcCatalog, it will make a request like one of the GetCapabilities requests (above) and you will see the list of operations and available Features.

Take a look however at the response of these GetCapabilities requests, it tells us that to do a GetFeature (and other) request(s) we need to use a different URL

<ows:Operation name="GetFeature">
  <ows:DCP>
    <ows:HTTP>
     <ows:Get xlink:href="http://204.62.18.180:8080/geoserver/wfs"/> 
     <ows:Post xlink:href="http://204.62.18.180:8080/geoserver/wfs"/>  
   </ows:HTTP>
 </ows:DCP>

So now in ArcMap a request is made to the location referenced in the GetCapabilities response (this is the correct behaviour), but the http://204.62.18.180:8080/geoserver/wfs URL does not appear to be publicly available, so no features are returned.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.