2

I have updated PostGIS to 2.4.3. Using with Postgresql 9.6 on Ubuntu 14. When I try to select ST_AsMvt(example_geometry) from example_table, I get:

 ERROR:  Missing libprotobuf-c
 ********** Error **********

 ERROR: Missing libprotobuf-c 
 SQL state: XX000

As it it mentioned on PostGIS Installation:

To enable ST_AsMVT protobuf-c library (for usage) and the protoc-c compiler (for building) are required. Also, pkg-config is required to verify the correct minimum version of protobuf-c.

If I execute protoc --version, I get libprotoc 3.5.0.

libprotobuf-c0, libprotobuf-c0-dev, libprotobuf-dev are already installed.

Tried sudo apt-get install --reinstall postgis but didn't help.

Related issues:

How to solve this problem?

  • You can solve this problem by installing libprotobuf-c on the system. – bugmenot123 Feb 12 '18 at 11:53
  • It seems that it's installed but ST_AsMvt still not work. – Justas Feb 12 '18 at 13:33
  • @Justas Do you have also libprotobuf-c-dev installed? – Stefan Feb 12 '18 at 13:59
  • No. I have installed libprotobuf-c0-dev – Justas Feb 12 '18 at 14:02
  • When I try to install libprotobuf-c-dev, I get E: Unable to locate package libprotobuf-c-dev – Justas Feb 12 '18 at 14:03
0

I don't have a direct solution to this problem. I'm in the same boat as the person who asked the question.

As a workaround, I have found using this Docker Image in place of my local DB to work. https://hub.docker.com/r/mdillon/postgis/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.