4

I am using google earth engine code editor to extract some band values at specific point locations. To do so I have loaded my .csv file with point IDs and coordinates into Fusion Tables and the Map looks ok, it displays all the 48455 points.

Points as displayed in Google Fusion Tables

I have then imported the fusion table as a Feature Collection in Earth Engine code editor, which seems to be ok as it says that the collection contains 48455 rows. However, the points located in South East Asia and Oceania are not displayed in the map.

Points as displayed in earth engine code editor. Points in south east Asia and Oceania are missing.

It seems not to be just mapping issue because when I run ReduceRegions to get the band values at the points I get NAs for those located south east asia and Australia. I have double checked the correctness of the coordinates by plotting the points in R and it worked fine. Thus, I guess it's not a projection issue either (they are all WGS84).

Link to fusion table: https://fusiontables.google.com/DataSource?docid=1n7yJSCuigXu6J-E5_NsUwHemVPyQ9R-NeNEFe-OA#map:id=3

Link to earth engine code: https://code.earthengine.google.com/95c044ed96d7ef0a1267ed5529736ef2

Someone can help me?

  • You need to share your fusion table. Set it to "anybody with link can view" so we can reproduce your problem. – Kersten Feb 15 '18 at 11:12
  • Sorry, it should be available now. – Riccardo Testolin Feb 15 '18 at 12:19
  • It is very interesting that when I make a copy of the fusion table, the missing points (South East Asia and Oceania) are missing in the fusion table's map too, but the features are still there. – Rodrigo E. Principe Feb 15 '18 at 18:06
  • Ideed. I have finally solved it using Aart's suggestion (convert the .csv file to .kml and reload it to fusion tables). I still wonder why this worked tho :) – Riccardo Testolin Feb 16 '18 at 11:13
-1

Your fusion table is not shared. I get a "permission denied" error.

You can upload your point map directly into the earth engine where they are stored in your assets. Convert your csv to shapefile and go to Assets -> table upload and select all files (shp,dbf, cpg, qpj, prj, shx).

  • 2
    this should be a comment, not an answer – Rodrigo E. Principe Feb 15 '18 at 11:35
  • It should be available now! – Riccardo Testolin Feb 15 '18 at 12:20
  • 2
    this is probably what you want. I converted your csv into a kml. Now you can use the geometry column to set the location. – Aart Feb 15 '18 at 16:08
  • Thanks so much Aart, it worked! I have made a copy of the new ft. How did you convert the .csv. to a .kml? – Riccardo Testolin Feb 16 '18 at 11:11
  • 1
    There is a "Add Delimited Text Layer" in the layer menu of QGIS. Set the lat and lon (column) from the csv file and save the result as a kml. – Aart Feb 17 '18 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.