1

I am trying to vectorize a raster with tree coverage information. I classified the data in 3 categories and now I am vectorizing the raster to make calculations and intersecting it with other layers.

The problem is that after vectorizing almost all polygons have invalid geometries because of missing nodes in the intersections. I attached an image where you can see the problem in the arrows. The selected polygon has 2 missing nodes.

I cannot use any vector tool with the layer because of this.

enter image description here

I need to intersect this layer with other complex one, but as a trial I do with a simple temporary layer and I have the same mistake: Input layer A contains invalid geometries (feature 71). Unable to complete intersection algorithm. (I dont know where to check what is feature71).

enter image description here

When I run the Topology checker it gaves me hundreds of mistakes with no valid geometry.enter image description here

I tried to check some of them and the only thing I find where the missing nodes, that is what I thought that was the problem.

  • 3
    They're not really 'missing', are they? The algorithm to convert the group of raster cells to polygon has no reason to put a vertex there. What application for this data cannot use this layer? – DPSSpatial Feb 14 '18 at 22:58
  • 2
    Why do you say they are invalid? does QGIS raise an error saying the geometry is problematic? If so, please copy the error and edit it in your question, so we can have a look at it (there's no reason for your polygon to be invalid due to not having extra nodes on edges). – Roberto Ribeiro Feb 15 '18 at 0:12
  • A wild guess would be that you have multi-part polygons but your layer is expecting single parts. – JGH Feb 15 '18 at 13:56
  • No multi-part problem. I alredy try the multipart to single part tool and intersect after, and same problem appears. – B RG Feb 15 '18 at 15:09
1

I was able to solve it using SAGA Intersect tool. I dont know why but this algorithm runs on the layers that were problematic at QGIS.

  • On the Stackexchange platform, we don't prefix question titles with SOLVED. Instead, you should be able to accept your own answer. – underdark Feb 17 '18 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.