0

I created a coverage layer ( polygon) for an atlas. It contains rectangle polygons which define the boundary of sheets (somehow irregular indexing along my layer). when I print the atlas without changing the scale of my map (scale 1:1600), I have the same overlap that I defined in my coverage layer (sheets polygon). But when I force to map to specific scale (1:1000) I lose the overlaps between the sheets. How can I change the coverage layer scale to 1:1000?

I know that I can use the option of best fitting scale, but I need to force my coverage scale to specific scale. enter image description here

  • you can have a fixed scale or a fixed extent but not both (unless you print on rubber sheets) – Ian Turton Feb 15 '18 at 13:19
  • As I said, my concern is the scale of coverage layer. there is no option to set the scale of coverage layer in qgis (as far as I see). If it was so, I could have designed/ modified my coverage layer to fit the desired scale. – A.Sarh Feb 15 '18 at 13:28
1

The scale of your map items is controlled by the size of your coverage polygons. Figure out what size polygon will give the desired scale on the size page you'll be printing. You can find this by setting the print composer map to the desired scale, then looking at the map's extent (under item properties).

Then resize the polygons in your coverage layer to that size. It may be easiest to create one polygon of the correct size, then copy-paste that polygon and move it to the desired locations.

Generate an atlas at either a fixed scale or zoomed to the coverage layer with a 0% margin. These setting should now give nearly identical results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.