0

I want to add an ArcGIS FeatureServer Layer into QGIS. I can add the layer sucessfully but as its being downloaded if I ask QGIS to do anything else it crashes.

First I bring up the Add ArcGisFeatureServer Layer from a Server dialog box. I can connect to the server fine as you can see in the screenshot. The url for the resource is http://maps.six.nsw.gov.au/arcgis/rest/services/public/NSW_Survey_Mark/MapServer. Then I click Add.

enter image description here

At first the dataset appears to be downloading fine.

enter image description here

When I attempt to zoom in on an area it initially looks ok but shortly crashes.

enter image description here

If I choose the debug option I get the following exception.

enter image description here

Am I adding the web service incorrectly? I've tried ticking on the Only request features overlapping the current view extent. No difference. I've added the layer when I was at a zoom level where I knew there are only 3 points. I get the blue loading bar but no features turning up. I assume its downloading them all over the state and not at the extent I'm zoomed to. If I attempt to move around then the same crash occurs.

I'm running QGIS 2.16.3.

  • I believe this was fixed in a more recent build - possibly 2.18.10 or above. – ndawson Feb 16 '18 at 0:41
  • Just tried to do the same process on 2.18.16. Same result. Same exception thrown. – koax26 Feb 16 '18 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.