1

I want to compose a CIR image in QGIS. Images are part of sample dataset downloaded from Micasense website.

I built virtual raster out of Red, Green and NIR rasters but the output file color scheme is different from publicly available ones. This is the image I treat as a benchmark:

enter image description here

In my case, combination of NIR, Red and Green generated following results:

enter image description here Purple color distinguishes ground instead of vegetation what is clearly visible.

I was able to generate something close to benchmark after adding the Blue band which (according to sources I based on) is not necessary. In this case plants are more reddish than purple, but definetely it was a step forward.

enter image description here

Is there any specific order of the bands I need to follow to achieve the required output?

Or maybe - when non satellite data is being used - Blue band should be included as well to obtain CIR imagery like on the benchmark?

  • What does your output look like? What do the images look like you hope to emulate? – lambertj Feb 20 '18 at 19:02
  • There are a few common band combinations earthobservatory.nasa.gov/Features/FalseColor/page6.php – user30184 Feb 20 '18 at 19:45
  • Thanks for suggestion guys. I believe I should add a bit more data in the first place, so I edited my post to provide more accurate description. – proteus Feb 21 '18 at 9:19
0

I have searched for long time to finally succeed that way: Works on QGIS 3.10 on Mac:

  • On Menu, open Raster/Miscealleous/Build virtual raster
  • Then choose the folder where your NIR.tif - RED.tif - GREEN.tif are located in "Input layers" - choose "Add files" and select the right folder and first your NIR.tif - then do so for the RED.tif and GREEN.tif
  • Select "Highest" resolution
  • Select "Allow projection difference"
  • And then clic on "Run" button and that's it! Remenber, first NIR then RED and then GREEN...
New contributor
Frano Kaaf is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

It looks like your bands are not in the correct order to create the false color composite you're after. In your image showing your output for the NIR, Red, and Green composite it looks like the NIR band is being rendered as Green.

By default the image will load in QGIS with the first band rendered as Red, second as Green and third as Blue. If you created your vrt file and used a different ordering of bands to how you would like them rendered you'll need to adjust this in the layer symbology options.

Right-click the layer, select Properties, then go to the Symbology tab. Here you can assign different bands in your file to the RGB colour space. For example, in the case where you created the file with the band order Red, NIR, Green you would assign your band 2 to the Red colour, band 1 to Green and band 3 to blue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.