1

In QGIS 2.18.16 with GRASS 7.4.0 (Windows 7, 64 bit), I am trying to create a composite raster layer from two nearly identical versions of a 3-band color geotiff that almost (but not quite perfectly) overlap, using the GRASS tool r.patch. Whether or not I select the "use zero for transparency instead of null," the process fails with the error message:

Input raster map contains cells with NULL-value (no-data). The value 255 will be used to represent no-data values in the input map. You can specify a nodata value with the nodata option. WARNING: The default nodata value is present in rasterband and would lead to data loss. Please specify a custom nodata value with the nodata parameter. ERROR: Raster export aborted.

Can anyone help me out with how to make this work within QGIS? There doesn't appear to be any way to set the nodata parameter within the r.patch dialogue box. Also, what value should I set it to?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.