There are slight differences in 2 shapefiles projection information. I have activated on-the-fly, but they do not plot in the same space. I tried to save as new shapefiles with the same CRS, but nothing changed. Here are the projection files followed by the properties shown in Qgis.



In layer spatial reference system units : xMin,yMin -176.732,51.712 : xMax,yMax -130.017,69.5665

Layer Spatial Reference System:

+proj=longlat +datum=WGS84 +no_defs

GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]]


In layer spatial reference system units : xMin,yMin -608773.35,761075.16 : xMax,yMax 1463871.73,2053821.27

Layer Spatial Reference System:

+proj=longlat +datum=WGS84 +no_defs

  • 1
    They are probably mislabeled then. i.e. Its re-projecting the shape-file from the wrong coordinate system to begin with. Might need to do some sleuthing to figure out which one is wrong and what its real coordinate system was/is.
    – Thad
    Commented Jun 11, 2012 at 17:32
  • You might find the reply at gis.stackexchange.com/a/27059 to be of some help, Doug. Please let us know whether that solves your problem.
    – whuber
    Commented Jun 11, 2012 at 17:35

1 Answer 1


The clue to your problem lies in the xMin,yMin and xMax,yMax of your respective layers.

The 1st layer has: xMin,yMin -176.732,51.712 : xMax,yMax -130.017,69.5665
This is clearly within the range of Latitude/ Longitude with Units of Degrees: Lat: 0-90, Lon: -180 - +180
This also matches with the WGS84 geographic projection as shown.

The 2nd layer has: xMin,yMin -608773.35,761075.16 : xMax,yMax 1463871.73,2053821.27 These bounds are clearly not within the range of the Latitude/Longitude coordinates. They look more like a Projected coordinate system with Units in Meters.

If you look at each of the CRS listed above, many of them list an EPSG (European Petroleum Survey Group) code. This is the standardized system that all of the CRS' refer to as used in QGIS. Here is the website where you may look up the appropriate CRS based on different parameters: EPSG Registry

Here is a screenshot of a search I ran using the Lat,Lon bounds you gave from your first layer: EPSG Registry Search

From looking at the search results, I can get some clues as to the location of your data, which seems to be in Serbia or thereabouts. In order to find the correct CRS for your 2nd layer, you need to go back to the source, or look in the metadata, as it should be described there.

What it looks like may have happened, is either your shapefile did not come with a ".prj" file, your layer has the wrong projection listed in the ".prj" file or QGIS did not correctly apply the projection when you added the layer. This has happened in the past as described in this Bug: 3746. That has been fixed though, so should not be the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.