QGIS 3.0 is released. However, in the download page, there does not seem to be an entry (for Ubuntu (16.04) at least):

Latest Release 2.18.x Las Palmas (new LTR)



Long Term Release Repository 2.14.x Essen (previous LTR)


Development Version 2.99.x master [4]



Which repository should be used to get the new QGIS 3.0?

  • 3
    Please, read in blog.qgis.org/2018/02/23/qgis-3-0-girona-is-released: "Once the release is done, our packagers will start preparing packages for different operating systems. We’ll keep you updated when different packages and installers become available".
    – xunilk
    Feb 24, 2018 at 12:59
  • 1
    I see in the mean time that QGIS is reverted to 2.14.22 (with the ubuntugis-unstable ppa repo)
    – Micha
    Feb 24, 2018 at 15:53
  • For someone interested in QGIS3 for Windows, this is the download link: download.osgeo.org/qgis/windows/?C=M;O=D
    – xunilk
    Feb 25, 2018 at 22:48

4 Answers 4


Just for the record, as of 02/24/2018, changing the repository from

deb http://qgis.org/ubuntugis-nightly xenial main


deb https://qgis.org/ubuntugis  xenial main

, and apt-get remove/install qgis worked. This installs qgis 3.0 and replaces 2.99dev.

The debian source: deb https://qgis.org/debian xenial main , however, does not seem to be update-to-date at present, and installs qgis-2.18.

  • I doubt that debian xenial will ever get updated, for the same reason the nightly version stopped updating in January: master for Xenial only available for ubuntugis (plain Xenial lacks GDAL 2).
    – AndreJ
    Feb 25, 2018 at 6:39

Even if the website text is not updated yet, https://qgis.org/debian already contains 3.0:

enter image description here

  • ... but only for artful and bionic. Xenial (and Linux Mint 18 using that) needs Ubuntugis, and older OS (trusty and Linux Mint 17) are out of luck with and without ubuntugis.
    – AndreJ
    Feb 25, 2018 at 6:42

As of June 2018, QGIS 3.2 installs on Ubuntu 16.04 with the following repositories:

deb http://qgis.org/ubuntugis xenial main

deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu xenial main

ubuntugis-unstable is critical, as http://ppa.launchpad.net/ubuntugis/ppa/ubuntu xenial main does currently not contain a recent enough libgdal20 (it contains 2.1.3, but >= 2.2.0 is needed).

  • 1
    ppa.launchpad.net/ubuntugis (i.e. ubuntugis-stable) was never meant to be used with QGIS repos.
    – AndreJ
    Jun 28, 2018 at 9:19
  • This worked for me
    – Lucas
    Apr 16, 2020 at 15:37

Just to summarize: Now during the transition to QGIS 3.0, on Ubuntu 16.04 and similar systems there are three possibilities:

  1. Using the ubuntugis repository you get updated to 3.0 but with no GRASS support. The GRASS plugin loads OK, but no access to GRASS maps in QGIS.
  2. If you use the debian repo you stay at 2.18.16 (the current "LTR") but also without GRASS support.
  3. And with the ubuntugis-unstable (ppa) repository you get reverted back to 2.14.22, and only in this version GRASS support is available.

Of course apt-get purge is needed after changing repos to switch between the different versions. So scratch item #2 above...

Edit: In the last few days, the recommended ltr repo now offers QGIS 2.18.17 and support for GRASS maps has returned. So scratch item #2 above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.