11

I installed QGIS 3.0.0 on a PC with French as default language. After changing the language of QGIS to English, the 'Vector' menu is empty and there is a French 'Vecteur' menu.

Any ideas how to fix this?

I cannot change the system language.

2
  • 1
    What happens if you run the OSGeo4W Shell (e.g. Start menu > All programs > QGIS 3.0 > OSGeo4W Shell) and type in qgis --lang en? – Joseph Feb 26 '18 at 15:00
  • Related to Incomplete raster menu in QGIS3 – underdark Mar 31 '18 at 19:16
10

There is already a bug reported for this problem.

In the meantime you can click "Reset to defaults" under Settings > Options > Processing and then restart QGIS. This removes the empty vector/raster menus.

3
  • Using QGIS 3.2 (Bonn), I do not have a Processing option when I go Settings > Options. – TheLastGIS Oct 21 '19 at 23:44
  • ... I don't have a processing option in the Settings>Options either... both in 3.16 and 3.18. I was operating 3.14 (I think) on the same laptop and had no problem... – 神戸ベアークリス Apr 24 at 3:01
  • I didn't have that option either, but I think that is because this is a different error. The OP's error was not the lack of the menu but that it was duplicated (french and english) and he only needed to remove the unused/empty one. My error was that I only had one empty menu. The processing tools were not loaded at all and that is why I didn't have the option under Settings, once loaded I do have it. Julio's answer below was the correct answer to my problem but not for the OP's. – Marc Compte Jun 4 at 13:48
8

I'm teaching qgis right now and several student have the same problem. The processing plugin deactivate by their self in several laptops. Just go to plugins/manage and install plugins and reactivate it

3
  • 1
    This was the root cause when my Vector menu disappeared. – TheLastGIS Oct 21 '19 at 23:43
  • This seems to be the most relevant answer for QGIS 3 – wfgeo Mar 6 '20 at 9:26
  • This worked for me when I disabled and then re-enabled the processing plugin. – donaddon Apr 14 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.