0

I am having a problem using the QGIS time manager plugin when adding a raster layer. It tells me that the format of the timestamp field (I converted it to a text column) that I am referencing did not succeed, but it looks like the data is in the correct format. My column is a text type in the table, as mentioned. Is there something that you can see that I may be doing wrong (print screens below)? I was also trying to follow advice for adding the timestamp column with formatting that I found here, but I still receive an error:

https://github.com/anitagraser/TimeManager/issues/159

enter image description here

enter image description here

the last character in the next screen is my cursor, not a pipe :)

enter image description here

enter image description here

OpenLayers preview of the timestamp column (text type) from GeoServer:

OpenLayers Preview from GeoServer

QGIS 2.14.20-Essen

Ubuntu 16.04

1

QGIS raster layers have no attributes. I'm not quite sure where the GeoServer updatetime is coming into play but I doubt that TimeManager can access it. Instead, you have to manually specify the timestamps as shown in How to configure Time Manager with Raster Data?

  • My apologies, and thank you for the response. I am new to geoserver, so I appreciate your patience.. I just read this post: anitagraser.com/2015/08/10/using-timemanager-for-wms-t-layers and I got a little further in both my progress and my understanding. However, now I am getting repeated authentication challenges in an "Enter Credentials" window. It looks like it is attempting to make the rest call now with the date range entered, but how do I set the authentication? It says "GeoServer Realm at localhost", Username: "admin?TIME=2018-01-08 00" and password prompt in the pop-up window – user1930364 Feb 26 '18 at 21:02
  • I reread the post that I referenced, and I added a new server (ie WMS connection) by doing Add Layer -> Connect -> and here I entered the credentials for the user, but still I get the credentials challenge each time the time manager attempts to call the rest api. The geoserver I am referencing is local and I can turn on/off authentication without effecting anyone else. Can I relax or remove the authentication for the WMS/WMTS service somehow? I reviewed the "Security" section of the GeoServer admin page, but I am not sure what to turn off to disable authentication for the rest calls. Thanks – user1930364 Feb 26 '18 at 22:06
  • Ok I removed the ?TIME=2018-01-08 portion from the user id that was popping up in the dialog, and then it retained the credentials for the subsequent calls. Thanks again and sorry for any confusion – user1930364 Feb 27 '18 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.