7

Is there a way to add TauDEM to the latest QGIS 3.0?

I can't see it in the providers tab as it was in my previous 2.18.14 version so I am unable to activate it. I use it pretty regularly so I would really like to get it added to this latest release as soon as possible to test out its new features.

  • no lo pude instalar, me pone estos mensaje, ayuda por favor! (Google translation: I could not install it, it puts these messages to me, help please! ) ModuleNotFoundError: No module named 'processing_taudem' Traceback (most recent call last): File "C:/PROGRA~1/QGIS3~1.6/apps/qgis/./python\qgis\utils.py", line 309, in loadPlugin __import__(packageName) File "C:/PROGRA~1/QGIS3~1.6/apps/qgis/./python\qgis\utils.py", line 672, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/Users/Usuario/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\processing-taude – user143365 May 20 at 18:41
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Vince May 20 at 19:03
5

TauDEM was removed from QGIS 3.0 as you mentioned in the changelog of QGIS 3.0: remove TauDEM provider from core Processing. The only solution for you for the time being is to use QGIS 2.18.17 (New LTR) which still supports TauDEM.

I am not sure if TauDEM will be added in the future or not, but at least you can still use it with QGIS 2.18 version.

  • 2
    The plan is for providers like taudem and lastools, which require external software to be installed and available, to be moved tov plugins in the qgis plugin repo. This currently requires someone to adopt these providers and take over their maintenance. – ndawson Feb 27 '18 at 20:43
  • @ndawson one of the great advantages of QGIS is that we can access external providers from inside QGIS. I hope someone will take care of these providers, or the developers of the external providers can adjust their tools to be compatible with QGIS 3.0 in the future. – ahmadhanb Feb 28 '18 at 0:50
  • If you're invested in using these providers, you could be the perfect candidate for taking up their maintenance! – ndawson Feb 28 '18 at 3:04
  • Unfortunately, I am not a developer. If I have developing skills I will be happy to help. – ahmadhanb Feb 28 '18 at 4:11
3

To solve this problem there is a plugin called 'processing for tauDEM' now available for QGIS3. you can download it from GitHub. Just change the name of the folder to processing_taudem when adding it to your plugins folder for it to install correctly.

To allow it to run correctly you must go to 'C:\Program Files\GDAL' and copy 2 files (this folder should have been created with the installation of TauDEM- I'm running windows so not sure about others)

'gdal201.dll'

'xerces-c_2_8.dll'

Paste these into 'C:\Program Files\QGIS 3.yourversionnumber\bin'

Set up TauDEM as normal as it will now be available in your providers list, but be wary of spaces in the file paths to the necessary folders. Mine did not work this way so I had to move them to

'C:\MicrosoftMPI\Bin'

'C:\TauDEM5Exe'

Once completed TauDEM will now run in QGIS3 but again the data you are working with can neither have spaces in the file name or the path, or you will still get the error message saying unable to create outputs.

Hope this helps someone as it was driving me nuts not being able to use the software in the new QGIS version.

This also works for QGIS 2.18. Using the old version still allows the filename and path to have spaces in it without falling over.

Again this is all tried and tested on Windows 10 so I am not entirely sure it applies to other OS running QGIS and TauDEM

1

I am getting an error when attempting to install QGIS 3.6. Can you confirm the following steps on Windows 10 install:

  1. Download TauDEM installer at http://hydrology.usu.edu/taudem/taudem5/downloads.html
  2. Download QGIS Plugin. https://plugins.bruy.me/plugins/plugins.xml find TauDEM and got to ‘Source Code’ download from github a zip file
  3. Change the name of the folder to ‘processing_taudem’ when adding it to your plugins folder for it to install correctly. Can you confirm this as changing the name of the unzipped folder in step 2?
  4. Go to 'C:\Program Files\GDAL' and copy 2 files ('gdal201.dll' and 'xerces-c_2_8.dll'). The folder should have been created with the installation of TauDEM in Step 1.
  5. Paste these into 'C:\Program Files\QGIS 3.yourversionnumber\bin'. I can’t see this location but I seem to have QGIS installed here ‘C:\OSGeo4W64\bin’
  6. Set up TauDEM as normal as it will now be available in your providers list, but be wary of spaces in the file paths to the necessary folders. Does this mean in QGIS go to ‘Setting’ > ‘Options’ > ‘Processing’ and then ‘turn on’ TauDEM? You said yours did not work this way you moved them 'C:\MicrosoftMPI\Bin' 'C:\TauDEM5Exe'? What exactly did you move, the files 'gdal201.dll' and 'xerces-c_2_8.dll'?

Screen shot of error message in QGIS

  • I am getting similar results as @Nic on QGIS 3.4.6. If I rename the processing-taudem-master to processing_taudem I get the Couldn't load plugin 'processing-taudem-master' error message. Leaving the directory named processing-taudem-master the error message reads 'Could't load plugin 'processing_taudem'. Any help is appreciated. – GBG Jul 18 at 18:20
0

I was following the directions in David's answer "to the T" and still having issues... then I realized I was trying to install from the master branch which is very far behind the latest release. So if anyone is having trouble with this, make sure you check the branches and download the latest version. After installing release 3.0 of the plugin it works perfectly.

  • Glad this worked for you, I was nearly at my wits end before i figured out a working solution. I have noticed that using this plugin with the model builder only works correctly in the QGIS LTR version 3.4.5. If run in 3.6 it will still give errors when run with other processes depending on the 1st TauDEM output, but no such error occurs in 3.4.5 if you are considering the model builder with the plug-in – David Laverty Jun 5 at 15:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.