I am trying to apply the "TPI-based landform classification" algorithm from SAGA. Originally in QGIS 2.14, on a MAC, then on windows and with SAGA standalone, but it quickly saturates memory/CPU and ends up crashing after a few minutes.

I have tried using a smaller elevation map, even with 10 x 10 pixels, as well as changing the projection of the data, but the issue remains the same.

Here is the log from QGIS:

Algorithm Tpi based landform classification starting... io_gdal 0 -TRANSFORM 1 -INTERPOL 0 -GRIDS "/var/folders/c3/b7snydx51hl3ytjckcs6bq580000gn/T/processing698bae80d9d24acab1a1ba0e08e8edcd/f96bf62b13bb4c3183ece82e146a4dba/DTMAlvaresASTERSAGAproj.sgrd" -FILES "/Users/yannick/Documents/Alvares/Base dados/ASTER DTM/DTM_Alvares_ASTER_SAGAproj.tif" ta_morphometry "TPI Based Landform Classification" -DEM "/var/folders/c3/b7snydx51hl3ytjckcs6bq580000gn/T/processing698bae80d9d24acab1a1ba0e08e8edcd/f96bf62b13bb4c3183ece82e146a4dba/DTMAlvaresASTERSAGAproj.sgrd" -RADIUS_A_MIN 0 -RADIUS_A_MAX 100 -RADIUS_B_MIN 0 -RADIUS_B_MAX 1000 -DW_WEIGHTING 0 -DW_IDW_POWER 1 -DW_IDW_OFFSET true -DW_BANDWIDTH 75 -LANDFORMS "/var/folders/c3/b7snydx51hl3ytjckcs6bq580000gn/T/processing698bae80d9d24acab1a1ba0e08e8edcd/1ed5f09736e4466a9521db2c1bee40fc/LANDFORMS.sdat"

## #####

SAGA Version: 2.2.3

library path: /Applications/QGIS.app/Contents/MacOS/lib/saga/ library name: libio_gdal library : GDAL/OGR tool : Import Raster author : O.Conrad (c) 2007 (A.Ringeler)

Parameters Grids: No objects Files: "/Users/yannick/Documents/Alvares/Base dados/ASTER DTM/DTM_Alvares_ASTER_SAGAproj.tif" Transformation: yes Interpolation: Nearest Neighbor

loading: /Users/yannick/Documents/Alvares/Base dados/ASTER DTM/DTM_Alvares_ASTER_SAGAproj.tif

Driver: GTiff Bands: 1 Rows: 470 Columns: 484

Transformation: x' = -8.161063 + x * 0.000278 + y * 0.000000 y' = 40.094790 + x * 0.000000 + y * -0.000278

loading band [1/1]

/Users/yannick/.qgis2//processing/saga_batch_job.sh: line 4: 37503 Killed: 9 saga_cmd ta_morphometry "TPI Based Landform Classification" -DEM "/var/folders/c3/b7snydx51hl3ytjckcs6bq580000gn/T/processing698bae80d9d24acab1a1ba0e08e8edcd/f96bf62b13bb4c3183ece82e146a4dba/DTMAlvaresASTERSAGAproj.sgrd" -RADIUS_A_MIN 0 -RADIUS_A_MAX 100 -RADIUS_B_MIN 0 -RADIUS_B_MAX 1000 -DW_WEIGHTING 0 -DW_IDW_POWER 1 -DW_IDW_OFFSET true -DW_BANDWIDTH 75 -LANDFORMS "/var/folders/c3/b7snydx51hl3ytjckcs6bq580000gn/T/processing698bae80d9d24acab1a1ba0e08e8edcd/1ed5f09736e4466a9521db2c1bee40fc/LANDFORMS.sdat" Converting outputs Loading resulting layers

The following layers were not correctly generated. Landforms You can check the log messages to find more information about the execution of the algorithm

  • 1
    I am probably wrong, but looking at ASTERSAGAproj.sgrd in your filename, can I understand that it's ASTER data? If yes, is your data projected? (Map unit is in meters? or in degrees?) I am wondering if the -RADIUS (100 and 1000) is the culprit, because SAGA uses map unit. Thanks!
    – Kazuhito
    Commented Feb 27, 2018 at 12:37
  • "Probably wrong"... but certainly 100% right !! Thanks a lot, I had tried different projections, but none of them had meter units. That was the trick ! Commented Feb 27, 2018 at 14:55

1 Answer 1


As identified by the comment from @Kazuhito, the solution was to reproject the data into a projection with meter units.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.