I have two points with the same location (with the same geometry point). It seems that I'm dealing with a overlapped selection bug because having those two points when I choose the second (the one on top) through the attribute table will be shown a highlight selection which is OK but if I choose the first one (the one below) it simply doesn't highlight. Which it is very confusing since that it means that the first point is a point without geometry, which is not true. When you have overlapped points QGIS will select only the top ones (in my case the last record on my table).

Is this a bug or in fact is a property that I can change in some place on QGIS settings? If so, where can I change that to show always the highlight selection for overlapped points?

Note: My QGIS version is 2.18.16

1 Answer 1


This isn't a bug. The bottom point is highlighted when you select it, but the top point covers it up completely.

In order to see highlighting on a point that is covered by another point, you'll need to change the symbology so that you can see both symbols at the same time. Here are a few ways to do this.

In all the images, I have two pairs of overlapping points. In the pair on the left, neither point is selected. In the pair on the right, the bottom point is selected.

  1. Use a completely transparent fill for the point symbol.

enter image description here

  1. Use a partially transparent fill. 50% opacity shown.

enter image description here

  1. Change the feature blending mode. Most of the options other than "Normal" will allow you to see when the bottom point is highlighed. enter image description here

Here's what "Dodge" blending mode looks like.

enter image description here

  1. Use the vertex markers that show up when the layer is in editing mode. Under Settings > Options > Digitizing > Vertex Markers > show markers only for selected features. Make sure the size of the vertex marker is larger than the point symbol. enter image description here enter image description here

These are just a few ways. There are many more options, including using data-defined settings to manipulate symbol size, shape or placement.

  • The mention issue is exactly that: "top point covers it up" to be honest it seems to me a usability bug/issue/suggestion. In fact I don't think that a 'selective feature' should inherit from layer properties (such as opacity). In my opinion, I think should behave in an independent way like Arcmap does. Changing my layer proprieties so the basic QGIS functionality can be shown is not intuitive. Thank you for your answer but I still see that is the workaround maybe is something that can be improved in future, maybe just a checkbox on 'Options' saying 'Show feature selection no matter what'.
    – ePascoal
    Mar 5, 2018 at 23:11
  • 1
    In that case, you should make a feature request. issues.qgis.org/projects/qgis
    – csk
    Mar 6, 2018 at 17:09
  • Update: in QGIS 3.0 there is a plugin called Highlighter which seems to do exactly what you want: "Highlight selected point or line features with a thick dot or line coloured in a user-defined colour. The layer whose features should be highlighted has to be defined in settings."
    – csk
    Mar 9, 2018 at 21:04
  • I tried to use the Highlighter for the same purpose but the selected features can not be cleared afterwards. Any idea how to do that ?
    – Serggg182
    Nov 27, 2020 at 15:46
  • @Serggg182 I have no idea. I never actually used the highligher plugin, I just saw from the description that it claimed to solve the problem. Plugins are user-made though, so if it doesn't work as advertised you should submit a bug request to the plugin designer.
    – csk
    Nov 28, 2020 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.