I don't do a lot of work with Rasters.

Basically I get a nice clean Raster when I use the "Topo To Raster" tool in 3D Analyst from a shapefile of contours.

enter image description here

This is a Rectangle (extent of my contours) so I need to clip it based on actual perimeter of my contours. But no matter if I Clip using the smaller boundary (minimum boundary tool) or Export

enter image description here

using that new smaller boundary, I always get a lower quality Raster that has some pix-elation going on.enter image description here

How do I create the same quality raster as the first, larger raster?

  • 1
    I don't use ArcGIS but look in the "Settings" tab to see if there's some kind of resampling happening. Change it to "nearest neighbor" instead of some interpolation scheme. There could also be a resolution mismatch that is causing the resampling. See if there's an option to export the clip with the same resolution as the original raster. (Also, what you call "smooth" is actually not smooth at all--it's a sharp discontinuity, but your point comes through.)
    – Jon
    Mar 1, 2018 at 18:23
  • @Jon- Nearest neighbor was automatically set in arcgis settings for the export BUT..I looked in the settings further and it was calculating statistics, building pyramids, etc. I turned all of that off and now the exported raster is nearly identical. Can you copy your comment below so I can give you credit for this answer? Thanks!
    – DaBears
    Mar 1, 2018 at 18:46
  • Glad you figured it out! Since you provided the solution (turn off statistics/pyramids) you should write the answer and accept it. There's a good chance that the actual underlying raster data is the same either way, but the display renders differently when you have pyramids.
    – Jon
    Mar 1, 2018 at 18:58

2 Answers 2


The solution is in the environment settings of your toolbox. By default ArcMap or ArcGIS Pro are set to use "Calculate Statistics" and "Build Pyramids", so these need to be unchecked or tweaked. Then the export or clip of the raster is nearly identical to the original raster look.

  • 1
    Don't forget to accept this answer.
    – Jon
    Mar 1, 2018 at 19:09
  • @Jon- I tried but it says "I have to wait two days" lol. I'll try to remember to come back and accept
    – DaBears
    Mar 1, 2018 at 19:23

Do not export the raster. Clip the raster. Looks like you are downsampling the raster resolution when you export

  • Create an area (polygon) of your extent (clipping mask) This should be a single feature in feature class.
  • Save Edits (Pro), Stop Editing (ArcGIS 10.x)
  • Run Clip Raster tool (Toolboxes -> Data Management Tools -> Raster Processing -> Clip)
  • Use the polygon you created as your output Extent
  • Once you select a polygon feature class the "Use Input Features for Clipping Geometry" check box appears -> check it
  • Run
  • Hi Jakub, I did these exact steps to create the sample screenshots above.
    – DaBears
    Mar 2, 2018 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.