-1

Debugging of model.  first black box shows the output variable value and second shows the value used by model builder instead of actual value.

I'm running ArcGIS 10.2.2 ModelBuilder. When I run my model which has an iterator, I have used an inline variable in the output path. When this model runs it writes output for the first two inputs then it uses the first output value for the rest of the outputs and overwrites them. So eventually I get two outputs the second one and the last one.

I have attached my model picture as well as debugging.

this model has an iterator which takes hdf files then feed it to extract subdataset tool then raster calculator tool ( both tool has MANAGED ticked) then Zonal Statistics as Table tool operates and give an output %output_value%. here Calculate Value tool has a python expression is %Value%[9:16] with an output variable outtput_value. )

  • Rather than showing us your whole model I think it would be better to present a test model that illustrates just the part that you are stuck on. Also, please present all output messages as text rather than pictures so that they are available to future searches. – PolyGeo Mar 3 '18 at 20:22
  • I wasted my 4 days because of internal bugs in ArcGIS 10.2.2. I just want to show this community that if they face such issue they should be aware. Now i'm using ArcgIS 10.3 and everything is fine, no issues no bugs. All i want to say is it's faulty to run models as a tool but you can do it in 10.3 version instead of 10.2.2. – Ritesh Porwal Mar 5 '18 at 9:10
1

I searched out an answer for the problem myself. I was using ArcGIS 10.2.2 and trying to run a model (with an iterator) as a tool. I was stuck for 4 days, and whatever I did it was generating only 2 outputs. I found out that model only outputted two files the second one and the last one. It generated the first two outputs finally then it started to overwrite the rest of the files from the name of first output file. I tried to get this working from all the way thought it is me doing something wrong.

But finally it was ArcGIS 10.2.2 which is having this major issue. I used ArcGIS 10.3 and now it is working fine. an ESRI thread about such issue

  • I just read some of that GeoNet thread and it looks like you encountered NIM098729 In ArcGIS for Desktop 10.2.1, when running a model with the Iterate Feature tool, an incorrect number of outputs are generated only when running the model as a tool. I think that there is a big difference between encountering a bug (which is fixed at the next dot release) and claiming a "horrible truth that ArcGIS 10.2.2 is bugged". – PolyGeo Mar 5 '18 at 9:18
  • Outputs are generated equally as the inputs but what this model (when runs as a tool) does is it runs for first and second iteration finely then it keeps overwriting all outputs with first file name. so eventually we get second and last outputs only. – Ritesh Porwal Mar 5 '18 at 9:28
  • There is an edit button beneath your answer that you can use to improve it. – PolyGeo Mar 5 '18 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.