1

I've been using Mint for 2 years but am still new to Linux. I had the default QGIS version (2.0 I think) installed and it worked great, but I tried to upgrade and lost even that. After experimenting I finally got rid of these 2 dependency problems

cpp-4.8 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04.3) but 4.8.4-2ubuntu1~14.04.4 is to be installed gcc-4.8 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04.3) but 4.8.4-2ubuntu1~14.04.4 is to be installed

but when I use sudo apt-get install qgis I get the error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
qgis : Depends: qgis-providers (= 2.14.22+dfsg-1~trusty1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I don't know how to install 2.14.22+dfsg-1~trusty1, if that's what I'm supposed to do. Since I got rid of the cpp and gcc packages I don't see anything else still broken in syaptic package manager.

I'm lost. My systen is: Thinkpad T410 i5 2.4 Ghz 4GB Dual boot Mint Cinnamon 17.3 64-bit, Windows 7 kernel 3.13.0-37-generic x86_64 (64 bit)

I'm really not sure where/how to add additional information that Andre requested so I'll put it here. After adding the additional source, key, and trying to install qgis I got: sudo apt-get install qgis [sudo] password for wayne: Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: qgis : Depends: libqgis-analysis2.18.17 but it is not going to be installed Depends: libqgis-app2.18.17 but it is not going to be installed Depends: libqgis-core2.18.17 but it is not going to be installed Depends: libqgis-gui2.18.17 but it is not going to be installed Depends: libqgis-networkanalysis2.18.17 but it is not going to be installed Depends: python-qgis (= 1:2.18.17+20trusty-ubuntugis) but it is not going to be installed Depends: qgis-providers (= 1:2.18.17+20trusty-ubuntugis) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

When I ran sudo apt-get install qgis-providers I got: Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: qgis-providers : Depends: libqgis-core2.18.17 but it is not going to be installed Depends: libqgis-gui2.18.17 but it is not going to be installed Depends: libspatialite5 (>= 4.0.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Then just now I tried sudo aptitude install qgis [sudo] password for wayne: The following NEW packages will be installed: libfcgi0ldbl{a} libgeos-3.4.2{a} libgeos-c1{a} libgsl0ldbl{a} libjs-jquery{a} libjs-leaflet{a} libqgis-analysis2.18.17{a} libqgis-app2.18.17{a} libqgis-core2.18.17{a} libqgis-customwidgets{a} libqgis-gui2.18.17{a} libqgis-networkanalysis2.18.17{a} libqgis-server2.18.17{a} libqgispython2.18.17{a} libqscintilla2-11{a} libqscintilla2-l10n{a} libqwt5-qt4{a} libspatialindex3{a} libspatialite5{a} python-dateutil{a} python-jinja2{a} python-matplotlib{a} python-matplotlib-data{a} python-psycopg2{a} python-pygments{a} python-pyparsing{a} python-pyproj{a} python-pyspatialite{a} python-qgis{a} python-qgis-common{a} python-qscintilla2{a} python-qt4-sql{a} python-shapely{a} python-tz{a} qgis qgis-common{a} qgis-providers{a} qgis-providers-common{a} qt4-designer{a} The following packages are RECOMMENDED but will NOT be installed: javascript-common liblwgeom-dev libqt4-dev python-egenix-mxdatetime python-tk qgis-plugin-grass qgis-provider-grass 0 packages upgraded, 39 newly installed, 0 to remove and 22 not upgraded. Need to get 64.2 MB of archives. After unpacking 245 MB will be used. The following packages have unmet dependencies: libgeos-c1v5 : Breaks: libgeos-c1 (< 3.4.2-8~) but 3.4.2-4ubuntu1 is to be installed. The following actions will resolve these dependencies:

  Keep the following packages at their current version:

1) libgeos-c1 [Not Installed]
2) libqgis-analysis2.18.17 [Not Installed]
3) libqgis-app2.18.17 [Not Installed]
4) libqgis-core2.18.17 [Not Installed]
5) libqgis-customwidgets [Not Installed]
6) libqgis-gui2.18.17 [Not Installed]
7) libqgis-networkanalysis2.18.17 [Not Installed]
8) libqgis-server2.18.17 [Not Installed]
9) libqgispython2.18.17 [Not Installed]
10) libspatialite5 [Not Installed]
11) python-pyspatialite [Not Installed]
12) python-qgis [Not Installed]
13) python-qgis-common [Not Installed]
14) python-shapely [Not Installed]
15) qgis [Not Installed]
16) qgis-providers [Not Installed]

Accept this solution? [Y/n/q/?]

Sounds tempting to accept, but I will wait for advice

OK, so I said yes and got this:

No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 22 not upgraded. Need to get 0 B of archives. After unpacking 0 B will be used.

Then I reinstalled the unstable ppa, updated the cache and got:

W: Failed to fetch http://packages.domain.com/dists/trusty/InRelease

W: Failed to fetch http://packages.domain.com/dists/trusty/Release.gpg Unable to connect to packages.domain.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.

I have no idea where

http://packages.domain.com/dists/trusty/InRelease

came from. But I got rid of it, and Halleluja! I am back where I started before I tried to upgrade. I have 2.18 back working again. I think I'll just be happy with 2.18. I dont want to go through this again, and there's nothing I need in later versions.

  • As a next step, try sudo apt-get install qgis-providers. I assume you have the ubuntugis-unstable ppa added to your sources, and disabled any qgis.org repo. You may run into the next missing dependency to be solved the same way, until everything works. – AndreJ Mar 4 '18 at 7:12
  • I ran that and got: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: qgis-providers : Depends: libqca2-plugins but it is not installable E: Unable to correct problems, you have held broken packages. – Bad medicine Mar 4 '18 at 14:34
  • 1
    You have to add it to your additional sources. No need to edit a file, Linux Mint has an icon for that. You may need to add the gpg key as noted on qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu – AndreJ Mar 4 '18 at 17:24
  • 1
    If you use sudo aptitude install qgis, you might get more detailed dependency errors. – AndreJ Mar 5 '18 at 17:53
  • 1
    You don't need libgeos-c1 with ubuntugis. If it is already installed, remove it. Ubuntugis comes with libgeos-c1v5. – AndreJ Mar 6 '18 at 7:08
2

Strange. I just updated from 2.14.11 to 2.18.17 on Mint 17.3 using https://qgis.org/ubuntugis-ltr trusty main as an additional repo without errors.

Disabling the qgis.org repo, and using only the ubuntugis unstable ppa throws the same error as you got. Seems to be a packaging error.

The dependent package is available for xenial and newer from the main ubuntu repo, not available on my Mint 17.3 (trusty), and not needed.


UPDATE

The dev's have fixed your problem with version 2.14.22+dfsg-1~trusty3.

  • Oh. I didn't see that. Not sure it matters now but thanks! I am going to format a new drive and install Mint 18.3 before I mess with any new versions of QGIS. – Bad medicine Mar 6 '18 at 17:21
1

This is a Virtual Machine of Linux Mint 18.1 for QGIS 3.0.

enter image description here

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
If qgis installed:
sudo apt-get upgrade
If you do not have qgis installed:
sudo apt-get install qgis

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.