1

Our map data is on CARTO.

We have 170,000 polygons on CARTO representing zoning data. I tried to export this data as GeoJSON from CARTO. Then I tried uploading it to MapBox Studio. The GeoJSON doesn't seem to be acceptable by MapBox.

Can you help us convert it into a format for Mapbox?

Below is the GeoJSON from CARTO.

{"type": "FeatureCollection", "features": [{"type":"Feature","geometry":{"type":"MultiPolygon","coordinates":[[[[50.535335,26.223457],[50.535441,26.22347],[50.535453,26.223386],[50.535364,26.223374],[50.535335,26.223457]]]]},"properties":{"parcel_size":92.2,"name":"4022656","block":"414","zoning":"RHB","zone_type":"ROW HOUSING (B)","builtareapercent":"300%","created_at":"2015-07-26T06:13:33Z","updated_at":"2015-07-26T09:27:21Z","cartodb_id":47}},{"type":"Feature","geometry":{"type":"MultiPolygon","coordinates":[[[[50.571541,26.22934],[50.571577,26.229347],[50.571635,26.229356],[50.57165,26.229266],[50.571558,26.229257],[50.571541,26.22934]]]]},"properties":{"parcel_size":92.2,"name":"3120962","block":"0302","zoning":"RHB","zone_type":"ROW HOUSING (B)","builtareapercent":"300%","created_at":"2015-08-10T06:55:55Z","updated_at":"2015-08-10T06:55:55Z","cartodb_id":127958}},{"type":"Feature","geometry":{"type":"MultiPolygon","coordinates":[[[[50.492856,26.093861],[50.492985,26.093891],[50.493,26.093841],[50.492958,26.09383],[50.49296,26.093822],[50.492929,26.093814],[50.492931,26.093806],[50.492877,26.093792],[50.492856,26.093861]]]]},"properties":{"parcel_size":92.2,"name":"15012911","block":"","zoning":"Unknown","zone_type":"PRIVATE RESIDENTIAL(B)","builtareapercent":"180%","created_at":"2015-10-29T13:15:16Z","updated_at":"2015-10-29T13:15:17Z","cartodb_id":193632}}]}

On uploading this GeoJSON as a new style in Mapbox Studio it is not being displayed

  • Welcome to GIS SE! As a new user be sure to take the Tour to learn about our focussed Q&A format. I recommend not thinking about GIS SE as being some sort of online GIS tutor. For your questions to be answered here they should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. – PolyGeo Mar 6 '18 at 1:38
  • 1
    Have you tried to open that GeoJSON file in other software like QGIS? What error Mapbox Studio gives to you? It's hard to help you without further details. – Jorge Sanz Mar 6 '18 at 10:49
  • This is not related to CARTO. GeoJSONs can be downloaded from any other source. Hopefully, Mapbox folks can give you a hand in this. – ramiroaznar Mar 7 '18 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.