1

enter image description here

I'm trying to build an attribute table for a raster in ArcMap.

The raster was created in QGIS because I needed to reclassify nodata pixels to have a zero value. ArcGIS Desktop is not letting me build the attribute table because the raster is not single band integer. It only has one band but somehow in the reclassifying process, the values got changed from integer to whole numbers or double, I'm not sure.

Is there a setting in QGIS to retain the integer value type when you reclassify so that you can later create an attribute table for it?

here is a screen clip of the Reclassify values dialogue box. I want to be able to set the values as integer/ no decimals

  • More detail would help. Why was it necessary to bring the raster into Q just to set nodata to 0? And what process did you use in QGIS to do the reclassification? Any chance you could throw in some screenshots? – JoshC Mar 6 '18 at 18:41
  • I don't have Spatial Analyst in ARC so I can't do the reclassifying with ARC. In QGIS I used SAGA>Raster Tools>Reclassify values, which worked pretty well, but it changed the value types and for some reason, ARC won't build a table for it. – Michael Gammon Mar 6 '18 at 18:44
  • Have you tried Raster Calculator? An expression like this might help: ("DEM@1" > 0)*"DEM@1" AND ( "DEM@1" = "nodata" ) * 0. Of course, the problem may be on the Arc side of things, but see if this gets you a better result. – JoshC Mar 6 '18 at 19:02
  • Unfortunately you need the Spatial Analyst Extension in order to use Raster Calculator. Is there a process in QGIS that would do this? – Michael Gammon Mar 6 '18 at 19:14
  • Sorry, that's what I meant. In QGIS, you can find Raster Calculator under the Raster menu. – JoshC Mar 6 '18 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.