I've noticed there is not an option to make the cell size for both X and Y the same when interpolating point data in QGIS 3.0.

When adjusting the cell size in QGIS 2.18, the columns would automatically adjust. Someone once told me the more ocean that is in the frame, the more askew the resultant interpolated raster will be, unless the cell sizes are set the same.

Below is a screen shot from 2.18

enter image description here

And from 3.0

enter image description here

This is an important feature for me because if the resultant raster pixels end up rectangular instead of square, any viewshed analysis I perform end up some 15-50km to the north of my area of interest.

  • Where did you find Interpolation in 3.0? I can't find it anywhere...!
    – gisol
    Commented Mar 10, 2018 at 10:47
  • It should be in the processing toolbar
    – James B
    Commented Mar 14, 2018 at 12:50

2 Answers 2


I remember this issue. The problem was that the Advanced viewshed plugin assumes that cells are square, irrespective of projection being used.

I don't see the Advanced viewshed plugin in Plugin manager for QGIS 3, I don't think it's been ported to QGIS 3

You could try GRASS r.viewshed which may not have that issue. It doesn't have a lot of the features of the plugin, though.

I would try that first on your rectangular-cell interpolated raster, to see if it works.

To create a TIN with fixed size cells, you might need to manually calculate the column and row counts for the TIN dialog. It should work if you have a projection in meters like UTM / OSGB.

Click on the . . . next to extent to populate the layer extent text box, and calculate:-

columns = (x_max - x_min) / cell_size
rows = (y_max - y_min) / cell_size

Not ideal, but a work-around. Hopefully someone can suggest a better way :)

  • Interpolation seems to be more stable in 3.0. As a short term solution I punch the desired cell size into QGIS 2.18 and copy the column and row values into the fields of the QGIS 3.0 dialog. As you correctly mention, there is no viewshed plugin for 3.0 yet so once I have the interpolated terrain data I bring it back in to 2.18 for analysis. Cheers
    – James B
    Commented Mar 14, 2018 at 12:52

Go to Plugins>Manage and install plugins; on the window which opens, go to Settings and activate the box "Show also experimental plugins"; when returning to the plugins catalogue you will find "Visibility analysis" on the list; current (still experimental) version is 0.6.5.

When installed, the plugin will not appear on the button bar; instead, it is installed by default in the Processing Toolbox, so you'll need to display it yo operate.

Hope this can be useful.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.