1

I have a raster layer (LIDAR data) selected. On releasing the mouse button, and before any rubber band starts, I get this error: Message log:

2018-03-09T16:19:08 WARNING Traceback (most recent call last): File "C:/Users/John/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\profiletool\tools\ptmaptool.py", line 78, in moved self.profiletool.rubberband.addPoint(QgsPoint(self.pointstoDraw[i][0],self.pointstoDraw[i][1])) TypeError: QgsRubberBand.addPoint(): argument 1 has unexpected type 'QgsPoint'

Can you help, please?

1

I uninstalled the plugin and donwload last zip from web page and it work again. The link is in the bug tracker in the plugin window in Qgis 3.

  • Thank you Marco. I just uninstalled the plugin and reinstalled using the plugin manager, but still have the same problem (QGIS 3.0.1 now). – user30578 Apr 16 '18 at 7:41
1

Based on Kantan answer, here is how to do using git:

  • Uninstall Profile Tool plugin, then close QGIS3
  • Open a git-enabled terminal, go to folder %User%\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins (or other QGIS3 plugin folder if different)
  • Type in terminal

    git clone https://github.com/etiennesky/profiletool.git

    cd profiletool

    git fetch origin pull/48/head:qgis3_compatibility

    git checkout qgis3_compatibility

  • Open QGIS 3. It should work

  • I had the same issue and tried this method, but it didn't work. It may require additional software or only work on some operating systems. downloading the zip file and copying it into the plugins directory did, work. – Brian Fisher May 8 '18 at 19:58
  • Well, I installed git, but Windows command didn't recognise git as a command. Tried in git command window, did the clone OK but >git fetch origin... generated C:\Users\John\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins>git fetch origin pull/48/head:qgis3_compatibility fatal: not a git repository (or any of the parent directories): .git. So I'm still stuck! – user30578 May 9 '18 at 18:51
  • user30578 : I forgot the "cd profiletool" line after the "git clone", sorry. Can you try the updated answer. – seb007 May 15 '18 at 8:45
0

The plugin hasn't been updated yet for Qgis 3.0. I was able to make it work using the proposed merges in the gitHub repository

First, locate where the plugin is saved (%User%\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins\profiletool by default)

Then, you want to replace those files with the ones proposed for the pull.

Either edit them manually or download and replace them all.

After that the plugin worked as it used to in Qgis 2.x.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.