2

I'm trying to compile QGIS 3.0 on Windows. I want to port it to Windows RT (Windows on Arm)

I keep getting this error:

Looking for gaiaStatisticsInvalidate in C:/OSGeo4W/lib/spatialite_i.lib
Looking for gaiaStatisticsInvalidate in C:/OSGeo4W/lib/spatialite_i.lib - not found
CMake Error at cmake/FindSpatiaLite.cmake:75 (MESSAGE):
  Found SpatiaLite, but version is too old.  Requires at least version 4.2.0
Call Stack (most recent call first):
  CMakeLists.txt:251 (FIND_PACKAGE)

How do I fix this? I have tried setting up OSGeo4W with spatialite 4.3, but it still thinks that my version is too old.

I have been following the install guide in the source code here

EDIT 1: According to CMAKE I get two errors: https://hastebin.com/woherijadi.tex

closed as off-topic by Vince, xunilk, whyzar, Jochen Schwarze, nmtoken Mar 11 '18 at 12:40

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions relating to general IT or with no clear GIS component, are off-topic here but can be researched/asked at Stack Overflow (software development), Super User (computing hardware and software), Database Administrators (relational databases) and other SE sites" – Vince, xunilk, whyzar, Jochen Schwarze, nmtoken
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.