2

Using Arcmap 10.3.1 I have published a featured service using My Hosted Services with a related table. I have confirmed the relation was working before publishing the service and can see the related table attributes using the web viewer of the feature service. I also confirmed I chose feature access instead of tiled mapping when publishing from service editor.

Now, I am trying to use Survey123 connect to build a survey off of this feature service (with related table). The survey creates questions from the standard database just fine, but nothing from the related table. I am expecting a "begin repeat" to show under the "type" xlsx form where the related table questions begin.

Is there a way to build the survey off of the feature service WITH the related table included in the Survey123 form?

1

In you relationship class is the label for the origin and destination table the same? This doesn't matter in AGOL maps, but does in survey123. If that doesn't fix it here is a demo on how to work with related tables in survey123 start at 43:45 https://www.youtube.com/watch?v=n5ytk52KlAk

1

Make sure that your relationship is based on GUID field types (ie, "GlobalID" fields). Also, check that the feature service supports applying edits with global IDs. The documentation states:

Repeats cannot reference related layers or tables unless the child layer or table uses a GUID field for the relationship. Although not a requirement in versions of ArcGIS Server supported by Survey123, best practice is to use a GUID field for the relationship in the parent layer. The feature service must support applying edits with global IDs

( https://doc.arcgis.com/en/survey123/desktop/create-surveys/survey123withexistingfeatureservices.htm )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.