6

I have LAZ files that I unpacked with laszip.exe, then I ended up with LAS files.

These files showed no error when making a LAS dataset in ArcGIS. I used this dataset several times without ant issues.

But when trying to use r.in.lidar in QGIS, I get this error:

ERROR: North must be north of South.

Since the files worked in ArcGIS, I am thinking this is a software or setup issue I have in QGIS.

I can't find that error message anywhere on the interweb.

1
  • 2
    Have you tried it in the stand alone GRASS that comes with QGIS? If you do so, you could print the output of g.region -p and r.in.lidar -sg input=(las file here) output=dummy -o
    – Marco
    Mar 12, 2018 at 12:24

2 Answers 2

3

I am reading the man page of GRASS 7:

Since the r.in.lidar generates a raster map through binning from the original LiDAR points, the target computational region extent and resolution have to be determined. A typical workflow would involve the examination of the LAS data's associated documentation or the scan of the LAS data file with r.in.lidar's -s (or -g) flag to find the input data's bounds.

Another option is to automatically set the region extents based on the LAS dataset extent (-e flag) along with the desired raster resolution using the resolution parameter. Link to Source

My guess is that you need to look at the options you are using and set a proper region extent

0
0

I used "System Administrator" to execute QGIS with GRASS and the error would not show.

1
  • 2
    Can you explain a little more?
    – MrXsquared
    Jun 1, 2021 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.