13

I just upgraded to QGIS 3.0 (OS X as well on Windows 10) and can not find out how to do some georeferencing. I am told by the software, that GDAL georeferencing is still installed and that I could not remove it, and that it should be in the category "raster". But I can not find it there, also not in other parts of the menu.

screenshot GDAL georeferencing plugin

new profile created, but the same issue...:

enter image description here

  • Is "GDAL Georeferencing" "active" in the plugin list? Tick the box next to the name in the plugin list. – Spacedman Mar 12 '18 at 21:02
  • Thanks a lot, but there is no clickable box next to "GDAL Georeferencing"... – Theresa Pommern Mar 12 '18 at 22:03
  • 1
    That looks broken - there should be a tickbox next to it like you have with "DB Manager". Try creating a new profile from the settings menu - this gives you a clean QGIS setup (you won't lose your current one) - and see if you get the same behaviour. – Spacedman Mar 13 '18 at 8:03
  • thanks a lot. So I have created a new profile, but...again there is no clickable box... – Theresa Pommern Mar 13 '18 at 8:29
  • 3
    Its not just the georeferencer - it seems all your core plugins except eVis have the same missing checkbox. Check the logs (View.. Panels.. Log Messages) I think you may need to report this as a QGIS issue. – Spacedman Mar 13 '18 at 10:32
10

I had the same issue. The bug is in the box.

Place the box next to Georeferencer plugin and activate it:

enter image description here

  • 2
    I just clicked the empty space where the box should be, and it worked. – Dùn Caan Jun 14 '18 at 17:19
6

A bug in your install.

enter image description here

You should be able to tick the box next to Georeferencer GDAL.

enter image description here

After which it will be in the Raster menu.

enter image description here

2

It's a bit confusing that you can't "uninstall" Georeferencer which I think, when I was first looking at QGIS3, I took to mean that it was installed and operational. I think there is a semantic/logic issue here. Does install mean that you've downloaded the plugin or that it's installed, that is, ready for use? The word missing in the plugin manager is activate. And the word "Search" appears right above the checkboxes for activation. Also when you're looking at "Not installed" plugin list, there is a blank spot to the left of the listed items where a checkbox might or might not be. For a seemingly simple window, a lot going uninstall (although some can't be), reinstall, upgrade; then lists of plugins and a settings icon mixed into the list. A very ambitious app and these minor UI inconsistencies are somewhat unavoidable. Thanks for the great app and all the hard work.

Searching for the item in the Plugin Manager sometimes changes the behavior of the check box.

1

For me the Georeferencer is actually not listed in the plugins list. Running QGIS 3.0.3 in Antergos.

enter image description here

0

I had the same problem. But, then I clicked on "Installed," searched for "georeferencer" and the check box appeared for me to choose it to activate. It appears under Raster now.

0

If you're using QGIS 3.2 on Arch, you need to install gsl (GNU Scientific Library) before the geo-referencer plugin shows in the plugin list. See dependencies here https://www.archlinux.org/packages/community/x86_64/qgis/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.