0

I just ran the ArcMap Mosaic to New Raster tool to merge 5 rasters of pH levels in different farms. These individual rasters have values that are decimals. When I run the tool, the output is in whole numbers. Why is this occurring and how do I change it? Could it be an environment setting, a tool property setting, or a data property setting? Nothing looks even remotely out of place. enter image description here

  • What specific type of raster is the mosaic? Right click raster layer > Source > Pixel Type & Pixel Depth – Aaron Mar 15 '18 at 13:02
3

You need to change the Pixel Type (optional) to 32_Bit_Float or 64_Bit, if you want decimals:

32_BIT_FLOAT—A 32-bit data type supporting decimals

64_BIT—A 64-bit data type supporting decimals.

enter image description here

By default it is 8_BIT_UNSIGNED, which means unsigned integer.

  • Ah, that was totally the problem. The rasters being merged were all 32 bit float. I just assumed the raster output file would be the same as the inputs. – gwydion93 Mar 15 '18 at 13:19
  • @jcbridwe Glad it solved the problem. Actually the downside of using 32_Bit_Float is that the file size will also increase. – ahmadhanb Mar 15 '18 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.