0

I have created a raster with a range of values from -1 to 1. I would like to extract a section by clipping to a polygon extent. I've been using Raster -> Extraction -> Clipper and QGIS has been giving me outputs clipped to the correct extent.

BUT - The data in each cell of the clipped versions of the raster are different from the original. For example, when there should be no data I'm getting numbers like 0.02 and 0.0314. Also, the field for nodata value = 3.40282e+38.

If I use gdalwarp I can change the nodata value to something outside of my -1 to 1 range (like -10 for example), but the cell values in the clipped raster are still different from my original raster. It seems that some kind of transformation is happening to the data during clipping.

Has anyone encountered this before?

1

Sometimes this is just a misconfiguration of the raster's display configurations. Try accessing the raster properties and check the options to load min/max value (the default is a 2 - 98% cut) and to use the real raster values (the default is a faster one. After that, click on "Load" and apply changes. Let me know if it solves your issue. I'm attaching an image below highlighting where you should click. My QGIS is in a different language, but the layout is the same and I don't think you'll have trouble finding your way around.Don't mind the language barrier here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.