I'm starting on a project with ArcGIS 10 where I'll be doing quite a bit of geocoding addresses. I understand the basics of how to do that. But a frustration on an earlier similar project is that when the boss would come down the hall with just a few more addresses for me to add to the map (over and over). So I would have to repeatedly re-geocode the whole table each time I add a few.

Thinking "there must be a better way", I came across the option on the geocoding dialog to create a dynamic feature class related to a table. This promises to automatically update the feature class when the data in the table changes. So I have tried this. I built a file geodatabase for this project, and imported some test data into it, and then geocoded the addresses. In ArcCatalog, I see my data table, the feature class, and a relationship class that links them.

However, when I edit an address in the table, I don't see any auto-updating going on. And more importantly, when I append more rows (via the Append toolbox item), they don't get auto-geocoded, either. Am I missing a step?

  • Maybe not exactly what you are looking for but you could just geocode the new address your given, then take the shapefile output from the geocoding process and add it into a feature class in your GDB using the "Load" function. You can just keep loading new addresses into the same feature class.
    – Boyle300
    Commented Jun 14, 2012 at 21:58

2 Answers 2


Rematching geocoded addresses after appending new data

You can use this 'Rematch Automatically button' that will:

Clicking the Rematch Automatically button takes the current result set and matches it automatically. If the result set contains a subset of all the addresses, only the subset will be automatically rematched. If the All Addresses result set is selected in the Show results drop-down list, the entire address table is completely rematched, which is like geocoding for the first time. The existing geocoding options are used in the rematch process, which can be adjusted with the Geocoding Options button on the bottom of the Interactive Rematch dialog box.

You can also select by the status and geocode only the unmatched.

enter image description here

ArcGIS 10.2 Rematching http://resources.arcgis.com/en/help/main/10.1/index.html#//002500000028000000

  • I can't figure out how to make this work. I started with 54 records in my table, and geocoded them successfully. Then I added 14 more. When I open the Interactive Rematch dialog (from ArcCatalog, I right-clicked the feature class and chose Review/Rematch Address). The dialog only shows my original 54 rows, which I expected because that's all that have been geocoded. ArcCatalog shows a relationship class linking the table and the feature class, but I can't see any way to make ArcGIS act on it. Commented Jun 15, 2012 at 20:14
  • are you using the Append (Data Management) with Schema_type=TEST applied? - resources.arcgis.com/en/help/main/10.1/index.html#//…
    – Mapperz
    Commented Jun 15, 2012 at 20:33
  • Yes. ArcToolbox/Data Management Tools/General/Append with Schema Type = TEST. Commented Jun 15, 2012 at 20:49

If not using the 'Append' tool, then what about the 'Merge'? This would still allow you to build the smaller discreet datasets with each of the additional data and yet combine it with the your continuously growing and consolidated list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.