I am reducing the size of a world timezone shapefile,


But at a 0.01 tolerance, entire countries disappear

Anybody know a way round this?

QGIS shows the same error simplifying naturalearthdatamaps also; simplify with 0.01 tolerance and Italy disappears


Looks like a known problem http://hub.qgis.org/issues/4189

The reason for wrong behavior is a tiny ring. If it is removed, the polygon is simplified ok. The polygons with bigger rings simplify ok, but if any polygon has a ring that is smaller than tolerance, it breaks the whole polygon.

  • Ah, thanks. Well found. Looks like I need to ogr2ogr until the fix the bug in QGIS – Paul Salber Jun 16 '12 at 21:55
  • I have tried GRASS and openjump on the timezone shapefile. The first simplifies but does not reduce filesize, the second crashes on an error. In order to progress, I am happy to contract help, anybody interested? – Paul Salber Jun 18 '12 at 9:36
  • 3
    mapshaper.com/test/MapShaper.swf simplifies shapefiles, and is robust to ocurrence of polygon rings smaller than the simplify tolerance. – Paul Salber Jul 1 '12 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.