I recently downloaded QGIS on a Mac OSX 10.7.4 (lion) and purchased a master map shape file, of a particular area.

I am trying to divide it into polygons following features on the master map vector file (.gml 2.shp) and it just won't snap. I have been to snapping and digitising options box, and ticked and changed tolerances far and wide but it just will not snap.

My map layer and topographic options are ticked. I've tried the general options tolerances and still it does not want to snap. I have tried changing vertex to segment and both to no avail, as well as pixels to map.

If I am working at 1:2500 map scale in metres what would a typical tolerance be? (tried 1- 50)

I think there must be a simple solution to enable snapping or have i down loaded file in the wrong format? In MapInfo one had to use keyboard strokes 'S' for snap and 'T' for trace, but this is not mentioned and you can be sure I have tried!

  • Are you working in British National Grid in QGIS?
    – Mapperz
    Jun 18, 2012 at 14:17

2 Answers 2


There is a dedicated plugin called traceDigitize. You can install it as long as you have the contributed repository. If you haven't got this then go to Fetch Plugins and then add it using http://pyqgis.org/repo/contributed.

The tool itself needs some work as you can't actually see the path you have traced. Though perhaps I'm just using it incorrectly.


Using the sample OS Matermap Dataset from http://www.ordnancesurvey.co.uk/oswebsite/products/try-now/sample-data.html

Loaded the GML file into QGIS (1.8RC1 here) and saved out a shapefile in British National Grid. (OSGB36 meters)

Then went into snapping mode and set the snapping to 2 meters (map units) to vertices.

Then used the split tool to test the snapping on a building outline and split the building.

enter image description here

(Note: I do find ArcGIS smoother than QGIS in the snapping tools control - but QGIS is doing the job for much less so it is worth testing)

  • Appreciated Mapperz. Yes am using OS GB 1936 British National Grid. Have found that if I zoom in works with rectangles - buildings for instance but on irregular edges, (I am trying to map different features in a woodland) you can see the polygon picking up the nodes but does not 'trace' the line you are following unless on laboriously clicks every node it hits. Just presuming there is trace feature to simplify this process.
    – Rupert
    Jun 18, 2012 at 20:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.