I installed QGIS 3.0 (standalone 64 bit installer) and added the standard XYX Tile layer 'OpenStreetMap' that was part of the install. It loads fine except the text is too small to see. Not sure if the small text size is caused by my high DPI (3200x1900) screen resolution? I also tried: 1. Adding my own XYZ Tile layer (instructions used were from here: http://www.xyht.com/spatial-itgis/using-openstreetmap-basemaps-qgis-3-0/) but the result was the same. 2. Adding a Google Maps layer (instructions used: http://www.geodose.com/2018/03/how-to-add-google-maps-layer-QGIS-3.html) and again, the text is too small to be usable.

Both OSM and Google Maps render the text at a readable size in my web browser (Chrome) so the issue is with QGIS 3.0 and not OSM or Google Maps.

Update - 1 April

I've had some suggestions to use high resolution (retina tiles). I tried the suggested links but the text in the maps were still too small. The links no longer work (it appears the services are no longer available) but I'm also not certain I used the correct URL either.

Can someone provide me with a URL to a working high resolution Open Street Map service.

Update - 7 April - Screen grab of the text size of in an XYZ tiles layer relative to other fonts. enter image description here


3 Answers 3


Have you made sure your maps are using the same CRS as the tiles and conform with the zoom level default scales? (see below)

Use the Same Native CRS as Tiles

Most XYZ tiles are produced in CRS - EPSG:3857 . When using a different CRS this can skew the image and make the labels more difficult to read. See below enter image description here

Conform with Zoom level default scales

XYZ tiles layers only produce labels at certain scales for a particular projection (typically CRS - EPSG:3857). Open street maps produces tiles at these default scales Zoom level Scales

So if you make sure any maps you produce use these same scales the labels should be legible. In the example below 1:4000 displays the same tile as 1:6000, but the 1:6000 is obviously not as legible enter image description here

  • Thanks Kapanther. I added a screen grab to the post above (sorry to all for not doing this sooner). CRS and zoom levels have no affect of the size of the fonts and other items. The tiles are clear but not usable. Did you do the above screen shots on a HiDPI monitor?
    – Colin
    Commented Apr 7, 2018 at 7:43
  • Scai suggested I try Retina Tiles and pointed me to a link the had some URLs to Retina examples. I tested them and the images were also small. I tried retesting but the links failed and was told that since I tried them the first time that the links Scai indicated have now been shut down. I'm just trying to find a confirmed URL that it guaranteed to be Retina Tiles to test.
    – Colin
    Commented Apr 7, 2018 at 7:48
  • Screen grabs taken on laptop screen max res 1920-1080. Its not HDPI.
    – Kapanther
    Commented Apr 8, 2018 at 9:26

I had this problem to when exporting an image just now and I figured it out. I just changed the DPI it's exporting at. It has nothing to do with monitor DPI as far as I know. 72 dpi worked well for me. You can find the setting under layout > export settings > export resolution:

export settings

  • Any idea why is this happening? Commented Aug 16, 2020 at 19:40

Since you are using raster tiles you can't change the text size of the labels. They are part of the tile image. However you can try switching to high-resolution tiles (also called retina tiles).

If this still doesn't fit then the only solution is using vector tiles where you can influence text rendering.

  • Thanks scai. I'm using a.tile.openstreetmap.org{z}/{x}/{y}.png. Can you tell me a URL the uses high-resolution tiles that I can switch to?
    – Colin
    Commented Mar 21, 2018 at 12:30
  • 1
    The link in my answer lists several tile sources, for example lyrk.
    – scai
    Commented Mar 21, 2018 at 12:35
  • I used one of the links you suggested "://mc.bbbike.org/mc/{z}/{x}/{y}.png" and there is no difference in text size. I don't understand why my browser can render the text at a readable size and QGIS 3.0 cannot. The issue seems to be with QGIS 3.0.
    – Colin
    Commented Mar 21, 2018 at 12:43
  • 1
    Rendering you own tiles (but with bigger text) is also an option. Whether it makes sense for you to do that depends rather on what you're doing with QGIS. If you want to change the underlying tile style anyway (and just overlay some stuff in QGIS) then it might make sense. Commented Mar 22, 2018 at 16:01
  • We use QGIS in a production environment with a small number of users. They use base maps like OSM in a multitude of workflows/use cases. QGIS is good for now but if the organisation's monitors are upgraded with HDPI monitors then QGIS can no longer be used...
    – Colin
    Commented Mar 31, 2018 at 3:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.