2

I have a personal geodatabase file (.mdb file), I open it with QGIS Las Palmas on windows 7. It is displayed perfect, but when I open table attributes for polygons, shape_area and shape_length have an unit that I don't understand, 100% not in meter or km, my crs is WGS84. How to convert these units in the table to meters?!! in order to save it later as csv?

  • You might need to reproject your data to a meter-based projected CRS to get results in that unit. Don't use EPSG:3857, it is not worth for any measurement. – AndreJ Apr 28 '18 at 13:17
1

Here is one method:

  1. Right click layer and select save as option and change the output coordinate crs option to some local utm projected coordinate system and save to a new shapefile
  2. Load shapefile into Q and open up attribute table, start edit session, open field calculator, and run the $area expression on the new field in field calculator
  3. This should provide you area values for each feature in meters. You may then right click on layer again in the and select save as and save to csv.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.