2

I have several layers from OpenStreetMap that I wanted to convert to WGS 84 4326 due to my using several base layers that are assigned to that CRS.

No matter what I try, whenever I check the layer they all say "this layer does not have a specified CRS"

Things I have tried:

Set project to WGS 84 4326.Turned OTF on and off. Set CRS in layer options and saved it and reloaded it. QGIS settings to prompt me when I add a layer missing a CRS which it does not prompt.

I have used a raster image to compare against my OSM layers and it would change accordingly to my projection change. Although it would never match the location of these OSM layers regardless of projection.

  • Is the OSM layer a web service, or data you've downloaded? – JoshC Mar 21 '18 at 23:02
  • It is data I've downloaded from: download.geofabrik.de I downloaded all of the SHP files I needed directly from there. – Chris Medyna Mar 21 '18 at 23:04
  • I downloaded a few shapefiles from the same source, and have no problem. Could you specify which shapefile you're using? Also, have you tried the "Assign CRS" tool? – JoshC Mar 21 '18 at 23:19
  • I have not tried that tool. Is it a plugin I can try? I downloaded all of the OSM SHP sets of Ontario and Quebec and NY state. Out of curiosity, with the layers loaded in QGIS, if you go to set layer CRS what does it say? I'd like to just compare what I see. Appreciate your help. – Chris Medyna Mar 21 '18 at 23:25
  • In QGIS 3, it's under the Vector General group in the processing toolbox. In QGIS 2.18, you could try using Define Current Projection under Vector > Data Management Tools. When I open the Set Layer CRS dialog, it just brings up the appropriate menu, and I am able to change it without issue. Perhaps add a screenshot of what you're getting. – JoshC Mar 21 '18 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.