I am testing three one way (ArcSDE 10 -> File Geodatabase) replicas. Each replica is derived from a layer created by selection by location from a citywide road dataset, so that each of the three layers is distinct from one another.

When I add features (all line layers) to the ArcSDE parent replica, all the features appear in the children after synchronization, as I would expect. The problem occurs when I delete any new test feature that is beyond the extent of the original dataset. If I first add a new feature beyond the dataset extent to the parent, this feature will be added to the child, but then when I delete the same feature in the parent, this feature will remain in the child after synchronization.

I do not have this issue when testing replicas that use the entire (non-selected) dataset. I have tried some different combinations of extent settings in the replica creation and in the environment settings but none have worked yet. I suspect this is related to the fact that these test features do not intersect the original extent...but I can add features outside of the extent, and I do not have this problem when testing a replica using the 'full' dataset.

Any ideas?

  • This really sounds like an item to bring up with ESRI Tech Support. They would likely be interested in trying to replicate this sort of a scenario as, like @blord mentioned, this sounds like a bug with the "Add" behavior. Commented Jun 19, 2012 at 0:58
  • Incidentally, are the file geodatabases version 10.0? Commented Jun 19, 2012 at 2:11

1 Answer 1


The new feature outside the extent should not be showing up in the child replicas.

Their new features should be limited to the extent of their original selection. The delete is actually behaving correctly, as the message for the delete should not be transmitted to the children since it is outside their extent. The add is behaving incorrectly.

  • Thanks for replies..yes the File GDBs are 10.0 (and I am using ArcEditor 10, on Windows XP)... So, if the 'add' is behaving incorrectly, how can I add a feature correctly that is outside of the original extent (say, if the new feature is intended to be an extension of the original extent)? I do not have this problem when using a 'full' un-selected dataset (I can add and delete features inside or outside the original extent).
    – Jason
    Commented Jun 20, 2012 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.