According to Opening MPK file without ArcGIS Desktop?, .mpk files are just .zip compressed and I should be able to unzip them as normal. I've tried from the terminal on macOS (10.11.6):

unzip somefile.mpk

for multiple different .mpk files I always get this error:

Archive:  somefile.mpk
 End-of-central-directory signature not found.  Either this file is not
 a zipfile, or it constitutes one disk of a multi-part archive.  In the
 latter case the central directory and zipfile comment will be found on
 the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of somefile.mpk or
        somefile.mpk.zip, and cannot find somefile.mpk.ZIP, period.

I get the same error if I change the file extension from .mpk to .zip. These files are known to work fine on Windows, when uncompressed with ArcGIS tools. They can also be unzipped with 7-zip on Windows.

Any idea what's going on here?

  • The duplicate may not seem exact at first but the answer of "Try .7z instead of .zip. the .*pk uses 7zip encoding and not zip" applies to an MPK as much as a GPK. – PolyGeo Mar 23 '18 at 5:46
  • I agree the solution is the same, but the questions seem distinct to me. The contexts are different - different error messages and different platforms. The underlying reason for the same solution working in both instances may in fact be the same. But someone asking either question will not necessarily know that the other question's answer is relevant. – jac Mar 23 '18 at 6:01
  • For that reason I propose that they are only made duplicates and not merged. – PolyGeo Mar 23 '18 at 6:16

I'm still not sure what's going on here, but with 7zip installed on the mac, I am able to uncompress the .mpk file from terminal using:

7z x somefile.mpk

Not the answer you're looking for? Browse other questions tagged or ask your own question.