12

I have installed QGIS3 from the AUR package, as well as all optional dependencies: https://aur.archlinux.org/packages/qgis/

However, when launching, I receive the following error:

Couldn't load plugin 'processing' 

ModuleNotFoundError: No module named 'osgeo' 
Traceback (most recent call last):
  File "/usr/share/qgis/python/qgis/utils.py", line 311, in loadPlugin
    __import__(packageName)
  File "/usr/share/qgis/python/qgis/utils.py", line 664, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/usr/share/qgis/python/plugins/processing/__init__.py", line 28, in 
    from processing.tools.dataobjects import *          # NOQA
  File "/usr/share/qgis/python/qgis/utils.py", line 664, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/usr/share/qgis/python/plugins/processing/tools/dataobjects.py", line 51, in 
    from processing.algs.gdal.GdalUtils import GdalUtils
  File "/usr/share/qgis/python/qgis/utils.py", line 664, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/usr/share/qgis/python/plugins/processing/algs/gdal/GdalUtils.py", line 35, in 
    from osgeo import gdal
  File "/usr/share/qgis/python/qgis/utils.py", line 664, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
ModuleNotFoundError: No module named 'osgeo'


Python version: 3.6.4 (default, Jan  5 2018, 02:35:40) [GCC 7.2.1 20171224] 
QGIS version: 3.0.0-Girona Girona, exported 

Python Path:
/usr/share/qgis/python
/home/thiago/.local/share/QGIS/QGIS3/profiles/default/python
/home/thiago/.local/share/QGIS/QGIS3/profiles/default/python/plugins
/usr/share/qgis/python/plugins
/usr/lib/python36.zip
/usr/lib/python3.6
/usr/lib/python3.6/lib-dynload
/usr/lib/python3.6/site-packages
/home/thiago/.local/share/QGIS/QGIS3/profiles/default/python

It seems to be a path issue, but I am not sure how to solve it. Pacman shows gdal and python-gdal both as installed.

3

Try to recompile your gdal and python-gdal. However, it may affect anything depending on them. You may need to recompile them as well. They are usually:

  • qgis
  • grass
  • saga-gis-ltr
  • liblas
2

Install the python missing module:

yaourt -S python-gdal

Then install the pip package:

pacman -S python-pip

and install the missing modules using:

pip install MissingModuleName
  • Installing python-gdal solved this issue for me. Seems they have forgotten a dependency. – Golar Ramblar May 16 at 13:06
2

Turns out the problem is that I had Anaconda Python installed and on the path, so python-gdal was compiled to the Anaconda path, instead of the regular system path. I removed Anaconda from path (editing the .bashrc file), then removed and recompiled python-gdal. Thank you all.

  • 2
    Hi, how do you do that? – Digd May 19 '18 at 19:01
2

Marcelo Villa Mar 27

This worked for me. "pip" that installed was an older version, prompting me to upgrade, but there are issues with the new version, apparently.

Since I am a newbie to Manjaro and all things Arch, learning the syntax is important. I am very familiar with the Ubuntu world, but this all seems new to me. Thanks Marcelo!

  • Instead of posting pictures containing code you should paste the code itself and format it with the {} button – Marcelo Villa May 29 '18 at 23:31
1

I've solved this by simply following the provided instructions in the QGIS 3.2 folder. It seems that the order of installation really does matter to get things right. In my case I was running the Python installation after the QGIS installation.

  1. Install Python. It should be a 3.6 version, the current 3.7 update doesn't make it easier. Herewith the link: https://www.python.org/downloads/release/python-366/

  2. Install GDAL with "2 Install GDAL Complete Complete.pkg"

  3. Install "3 Install QGIS 3.pkg"

0

I just had to reinstall gdal and QGIS3 using their installers and the problem went away. I didn't even remove my existing versions first. It was fast, so hope that works for you too!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.