4

I'm trying to get a network in shape (pain, such unending pain) and have turned to Check Geometry to find errors but I repeatedly get told that "The test layer set contains a layer selected for a topology check". I have no idea what this means and I can't find it anywhere except in the python file for the tool interface. The first file I tried didn't work so I simply exported it as a new file and then it worked but that trick is no longer working. Does anybody know what this error actually means and how to get around it?

closed as unclear what you're asking by whyzar, nmtoken, aldo_tapia, xunilk, PolyGeo Mar 29 '18 at 22:49

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Using the grass modules I managed to improve the network. It's not perfect but much better. My question about Check Geometry still stands though. – mercergeoinfo Mar 23 '18 at 15:42
  • What version of QGIS? What type of file is the layer? – csk Mar 23 '18 at 16:26
1

In the topology checks section of the Geometry Checker, there are two tests that compare the input layers with external layers: "Lines must not intersect with features of layer ..." and "Polygons must follow boundaries of layer ...".

Your error means that you activated one of these two tests, and chose a layer that was also one of the input layers, which does not really make sense.enter image description here

  • Unfortunately that doesn't seem to be the case. I have tested by checking different geometry errors and (as I mentioned) by exporting the file and running on that exported copy. This sometimes stops the error, but sometimes not. I shall report the behaviour as a bug as it seems it is inconsistent and not actually related to the file type, data type or geometry type. – mercergeoinfo Apr 3 '18 at 15:17
  • Are you sure that you disabled the "Lines must not intersect with features of layer" and "Polygons must follow boundaries of layer"? If they are disabled, this message cannot appear. – Leyan Apr 3 '18 at 19:00
  • "Cannot" is not a word in the language of frustrating errors. Which is really my point. The behaviour doesn't seem to be normal but rather a bug, I am running QGIS 3.0 so such things are to be expected. – mercergeoinfo Apr 4 '18 at 18:37
  • You may not have checked the box, but if the text showing the name of the layer is not greyed out, just check the box then uncheck it. The layer text should then be grey, and the error message will not appear. – Dr Richard Langford Nov 20 '18 at 5:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.